ACM-ICPC 2018 沈阳赛区网络预赛 I(模拟)

版权声明:本文为博主原创文章,转载请标明博主信息:https://blog.csdn.net/weixin_39453270 https://blog.csdn.net/weixin_39453270/article/details/82533686

传送门

题面:

LATTICE is learning Digital Electronic Technology. He is talented, so he understood all those pieces of knowledge in 10^{-9}10−9 second. In the next 10^{-9}10−9 second, he built a data decoding device that decodes data encoded with his special binary coding rule to meaningful words.

His coding rule is called "prefix code", a type of code system (typically a variable-length code) distinguished by its possession of the "prefix property", which requires that there is no whole code word in the system that is a prefix (initial segment) of any other code word in the system. Note that his code is composed of only 00 and 11.

LATTICE's device only receives data that perfectly matches LATTICE's rules, in other words, people who send message to LATTICE will always obey his coding rule. However, in the process of receiving data, there are errors that cannot avoid, so LATTICE uses parity check to detect error bytes, after every 88-bit data there is 11 bit called parity bit, which should be '0' if there are odd number of '1's in the previous 88 bits and should be '1' if there are even number of '1's. If the parity bit does not meet the fact, then the whole 99 bits (including the parity bit) should be considered as invalid data and ignored. Data without parity bit is also considered as invalid data. Parity bits will be deleted after the parity check.

For example, consider the given data "101010101010101010101010", it should be divided into 33parts:"101010101","010101010" and "101010". For the first part, there are 44 '1's in the first 88 bits, and parity bit is '1', so this part passed the check. For the second part, there are 44 '1's and parity bit is '0', so this part failed the check. For the third part, it has less than 99 bits so it contains no parity bit, so this part also failed the check. The data after parity check is "10101010", which is the first 88 bits of first part.

Data passed the parity check will go into a process that decodes LATTICE's code. The process is described in the following example: consider a situation that, "010" represents 'A' and "1011" represents 'B', if the data after parity check is "01010110101011010010", it can be divided into "010"+"1011"+"010"+"1011"+"010"+"010", which means "ABABAA" . LATTICE's device is so exquisite that it can decode all visible characters in the ASCII table .

LATTICE is famous for his Talk show, some reporters have sneaked into his mansion, they stole the data LATTICE to decode in hexadecimal, the coding rule consists of NN pairs of corresponding relations from a bit string S_iSi​ to an ASCII code C_iCi​, and the message length MM, they want to peek his privacy so they come to you to write a program that decodes messages that LATTICE receives.

Input

The first line an integer T\ (T<35)T (T<35) represents the number of test cases.

Every test case starts with one line containing two integers, M\ (0<M\leq100000)M (0<M≤100000), the number of original characters, and N\ (1\leq N \leq 256)N (1≤N≤256), then NN lines, every line contains an integer C_iCi​, and a string S_i(0<|S_i|\leq 10)Si​(0<∣Si​∣≤10), means that S_iSi​ represents C_iCi​, the ASCII code to a visible character and S_iSi​ only contains '0'or '1' and there are no two numbers ii and jj that S_iSi​ is prefix of S_jSj​.

Then one line contains data that is going to be received in hexadecimal. (0<|data|<200000)(0<∣data∣<200000).

Output

For each test case, output the decoded message in a new line, the length of the decoded message should be the same with the length of original characters, which means you can stop decoding having outputted MM characters. Input guarantees that it will have no less than MM valid characters and all given ASCII codes represent visible characters.

Hint

Lattice's encoding rule for test case 22:

扫描二维码关注公众号,回复: 3160750 查看本文章
ASCII code character lattice's code
4949 11 00010001
5050 22 0100101001
5151 33 011011

the device takes this input in hex

 

1

14DB24722698

input in binary

 
 

1

0001 0100 1101 1011 0010 0100 0111 0010 0010 0110 1001 1000

formatted into 66 lines, each line contains 88 data bits and one parity bit

 
 

1

00010100 1

2

10110110 0

3

10010001 1

4

10010001 0

5

01101001 1

6

000

parity check of the third line and the last line failed, so ignore those two lines.parity bits should also be ignored.

 
 

1

00010100

2

10110110

3

10010001

4

01101001

arrange those bits by the rules informed

 
 

1

0001 01001 011 011 01001 0001 011 01001

output the result

 
 

1

12332132

样例输入复制

2
15 9
32 0100
33 11
100 1011
101 0110
104 1010
108 00
111 100
114 0111
119 0101
A6Fd021171c562Fde1
8 3
49 0001
50 01001
51 011
14DB24722698

样例输出复制

hello world!!!!
12332132

题目来源

ACM-ICPC 2018 沈阳赛区网络预赛

题意:

    第一行一个t,代表有t组样例,第二行一个n,一个m,分别代表解码后的字符串的长度和字符表之间的关系。

    后m行有一个数num,和字符串b,分别代表ASCLL码为a的字符映射数b。

    最后给你一个十六进制的码,让你进行解码。

    解码的过程如下:首先要将十六进制码转化为二进制码,并将二进制码分为k份,每份长度为9,长度不足为9的则舍弃。

而对于每一份二进制码str,最后一位为标记id,首先统计前8位的1的个数cnt,倘若cnt为奇数,且标记id为0,则保留;若cnt为偶数,且标记id为1,则保留。将符合条件的str的前8位继续保留并组成新的码str2,并按照m个字母表的映射将str2转化为ASCLL码。

题目分析:

    不想吐槽这个题,题目相当丑长。但是整个题面翻译过来就是题解。

    明白提议之后直接模拟既可。

#include <bits/stdc++.h>
using namespace std;
unordered_map<char,string>mp;
unordered_map<string,int>table;
string code;
string decode;
string ddcode;
vector<int>vec;
int main()
{
    int t;
    scanf("%d",&t);
    mp['0']="0000";
    mp['1']="0001";
    mp['2']="0010";
    mp['3']="0011";
    mp['4']="0100";
    mp['5']="0101";
    mp['6']="0110";
    mp['7']="0111";
    mp['8']="1000";
    mp['9']="1001";
    mp['A']="1010";
    mp['B']="1011";
    mp['C']="1100";
    mp['D']="1101";
    mp['E']="1110";
    mp['F']="1111";
    mp['a']="1010";
    mp['b']="1011";
    mp['c']="1100";
    mp['d']="1101";
    mp['e']="1110";
    mp['f']="1111";
    while(t--){
        int m,n;
        scanf("%d%d",&m,&n);
        table.clear();
        decode.clear();
        ddcode.clear();
        vec.clear();
        for(int i=0;i<n;i++){
            int num;
            string str;
            cin>>num>>str;
            table[str]=num;//记录映射
        }
        cin>>code;
        int len=code.length();
        for(int i=0;i<len;i++){
            decode+=mp[code[i]];//十六进制转化二进制
        }
        len=decode.length();
        string tmp;
        for(int i=0;i<len;i+=9){
            tmp=decode.substr(i,9);//取9位字符
            int cnt=0;
            if(tmp.length()!=9) break;
            for(int j=0;j<8;j++){//统计前8位的字符中1的个数
                if(tmp[j]=='1') cnt++;
            }
            //分别判断是否合法
            if(cnt%2==0&&tmp[8]=='1') ddcode+=tmp.substr(0,8);
            if(cnt%2==1&&tmp[8]=='0') ddcode+=tmp.substr(0,8);
            tmp.clear();
        }
        len=ddcode.length();
        tmp.clear();
        for(int i=0;i<len;i++){
            tmp+=ddcode[i];
            if(table.count(tmp)) {//如果当前储存的字符串在字符中字母表中有映射,则保存答案
                vec.push_back(table[tmp]),tmp.clear();
            }
        }
        int sz=vec.size();
        for(int i=0;i<sz;i++){
            if(i==m) break;
            printf("%c",vec[i]);
        }
        puts("");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_39453270/article/details/82533686