2018 徐州网络赛 B

  •  262144K
 

In a world where ordinary people cannot reach, a boy named "Koutarou" and a girl named "Sena" are playing a video game. The game system of this video game is quite unique: in the process of playing this game, you need to constantly face the choice, each time you choose the game will provide 1-313 options, the player can only choose one of them. Each option has an effect on a "score" parameter in the game. Some options will increase the score, some options will reduce the score, and some options will change the score to a value multiplied by -11 .

That is, if there are three options in a selection, the score will be increased by 11, decreased by 11, or multiplied by -11. The score before the selection is 88. Then selecting option 11 will make the score become 99, and selecting option 22 will make the score 77 and select option 33 to make the score -88. Note that the score has an upper limit of 100100 and a lower limit of -100100. If the score is 9999 at this time, an option that makes the score +2+2 is selected. After that, the score will change to 100100 and vice versa .

After all the choices have been made, the score will affect the ending of the game. If the score is greater than or equal to a certain value kk, it will enter a good ending; if it is less than or equal to a certain value ll, it will enter the bad ending; if both conditions are not satisfied, it will enter the normal ending. Now, Koutarou and Sena want to play the good endings and the bad endings respectively. They refused to give up each other and finally decided to use the "one person to make a choice" way to play the game, Koutarou first choose. Now assume that they all know the initial score, the impact of each option, and the kk, ll values, and decide to choose in the way that works best for them. (That is, they will try their best to play the ending they want. If it's impossible, they would rather normal ending than the ending their rival wants.)

Koutarou and Sena are playing very happy, but I believe you have seen through the final ending. Now give you the initial score, the kk value, the ll value, and the effect of each option on the score. Can you answer the final ending of the game?

Input

The first line contains four integers n,m,k,ln,m,k,l(1\le n \le 10001n1000, -100 \le m \le 100100m100 , -100 \le l < k \le 100100l<k100), represents the number of choices, the initial score, the minimum score required to enter a good ending, and the highest score required to enter a bad ending, respectively.

Each of the next nn lines contains three integers a,b,ca,b,c(a\ge 0a0 , b\ge0b0 ,c=0c=0 or c=1c=1),indicates the options that appear in this selection,in which a=0a=0 means there is no option to increase the score in this selection, a>0a>0 means there is an option in this selection to increase the score by aa ; b=0b=0 means there is no option to decrease the score in this selection, b>0b>0 means there is an option in this selection to decrease the score by bb; c=0c=0 means there is no option to multiply the score by -11 in this selection , c=1c=1 means there is exactly an option in this selection to multiply the score by -11. It is guaranteed that a,b,ca,b,c are not equal to 00 at the same time.

Output

One line contains the final ending of the game. If it will enter a good ending,print "Good Ending"(without quotes); if it will enter a bad ending,print "Bad Ending"(without quotes);otherwise print "Normal Ending"(without quotes).

样例输入1

3 -8 5 -5
3 1 1
2 0 1
0 2 1

样例输出1

Good Ending

样例输入2

3 0 10 3
0 0 1
0 10 1
0 2 1

样例输出2

Bad Ending

题目来源

ACM-ICPC 2018 徐州赛区网络预赛

思路:

倒退的dp。

#include <bits/stdc++.h>
using namespace std;
const int maxn=1010;
int dp[maxn][210];
int n,m,l,r;
int a[maxn][3];
int main(){
    // freopen("in.txt","r",stdin);
    scanf("%d%d%d%d",&n,&m,&l,&r);
    m+=100,l+=100,r+=100;
    for (int i=0; i<=200; i++) dp[n+1][i]=i;
    for (int i=1; i<=n; i++){
        for (int j=1; j<=3; j++)
            scanf("%d",&a[i][j]);
    }

    for (int i=n; i>=1; --i){
        for (int j=200; j>=0; --j){
            if(i&1){
            dp[i][j]=0;
                if(a[i][1])
                    dp[i][j]=max(dp[i][j],dp[i+1][min(j+a[i][1],200)]);
                if(a[i][2]) 
                    dp[i][j]=max(dp[i][j],dp[i+1][max(j-a[i][2],0)]);
                if(a[i][3])
                    dp[i][j]=max(dp[i][j],dp[i+1][200-j]);
            } else {
                dp[i][j]=200;
                if(a[i][1])
                    dp[i][j]=min(dp[i][j],dp[i+1][min(j+a[i][1],200)]);
                if(a[i][2]) 
                    dp[i][j]=min(dp[i][j],dp[i+1][max(j-a[i][2],0)]);
                if(a[i][3])
                    dp[i][j]=min(dp[i][j],dp[i+1][200-j]);
            }
        }
    }
    int ans=dp[1][m];
    if(ans>=l) puts("Good Ending");
    else if(ans<=r) puts("Bad Ending");
    else puts("Normal Ending");
    return 0;
}
View Code

猜你喜欢

转载自www.cnblogs.com/acerkoo/p/9638072.html