angel

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 29   Accepted Submission(s) : 16

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M. Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

 

7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........

Sample Output

 

13

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<string.h>
#include<algorithm>

using namespace std;

int n,m,ans,ok;
char map[201][201];
int vis[201][201];
void dfs(int x,int y,int step)
{
    if(vis[x][y] || map[x][y]=='#' || step>=ans)
        return;
    if(map[x][y]=='a')
    {
        ok=1;
        if(step<ans)
            ans=step;
        return ;
    }
    if(map[x][y]=='x')
        step++;
    vis[x][y]=1;
    dfs(x+1,y,step+1);
    dfs(x-1,y,step+1);
    dfs(x,y+1,step+1);
    dfs(x,y-1,step+1);
    vis[x][y]=0;
}
int main()
{

    while(~scanf("%d %d%*c",&n,&m))
    {
        memset(map,'#',sizeof(map));
        int i,j,sti,stj;
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=m; j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j]=='r')
                {
                    sti=i;
                    stj=j;
                }
            }
            getchar();
        }
        ok=0;
        ans=100000;
        dfs(sti,stj,0);
        if(ok)
            printf("%d\n",ans);
        else
            printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/masterwu1/article/details/82562061