poj 2559 Largest Rectangle(单调栈)

Largest Rectangle in a Histogram

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 26549   Accepted: 8581

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 


Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

单调栈入门题...


#include<bits/stdc++.h>
#include<stdio.h>
#include<iostream>
#include<cmath>
#include<math.h>
#include<queue>
#include<set>
#include<map>
#include<iomanip>
#include<algorithm>
#include<stack>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
int n;
int a[100005];
int st[100005];
int L[100005];
int R[100005];
int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLIN
    while(1)
    {
        scanf("%d",&n);
        if(n==0)break;
        for(int i=1;i<=n;i++)scanf("%d",&a[i]);
        stack<int>st;
        for(int i=1;i<=n;i++)
        {
            while(!st.empty()&&a[st.top()]>=a[i])st.pop();
            if(st.empty()){L[i]=1;st.push(i);continue;}
            L[i]=st.top()+1;
            st.push(i);
        }
        while(!st.empty())st.pop();
        for(int i=n;i>=1;i--)
        {
            while(!st.empty()&&a[st.top()]>=a[i])st.pop();
            if(st.empty()){R[i]=n;st.push(i);continue;}
            R[i]=st.top()-1;
            st.push(i);
        }
        
        ll ans=0;
        for(int i=1;i<=n;i++)
        {
            ans=max(ans,1ll*a[i]*(R[i]-L[i]+1));
        }
        printf("%lld\n",ans);
    }
    return 0;
}


















猜你喜欢

转载自blog.csdn.net/linruier2017/article/details/82352333
今日推荐