1073 Scientific Notation (20分)【字符串处理】

1073 Scientific Notation (20分)

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000
#include<iostream>
#include<string>
using namespace std;

int main()
{
	string str;
	cin >> str;
	int len = str.length();
	if (str[0] == '-')
		cout << '-';
	int ePos = 0;
	while (str[ePos++] != 'E');
	int exp = 0;
	for (int i = ePos + 1; i < len; i++)
	{
		exp = exp * 10 + str[i] - '0';
	}
	if (exp == 0)
	{
		for (int i = 1; i < ePos; i++)
		{
			cout << str[i];
		}
	}
	if (str[ePos] == '-')    //如果指数为负数
	{
		cout << "0.";
		for (int i = 0; i < exp - 1; i++)
		{
			cout << "0";
		}
		cout << str[1];       //输出了除小数点以外的数字
		for (int i = 3; i < ePos - 1; i++)
			cout << str[i];
	}
	else               //否则指数为正
	{
		for (int i = 1; i < ePos-1; i++)    //输出小数点移动后的数
		{
			if (str[i] == '.')      //小数点不输出
				continue;
			cout << str[i];
			if (i == exp + 2 && ePos - 4 != exp)    //移动后的小数点
			{
				cout << ".";
			}
		}
		for (int i = 0; i < exp - (ePos - 4); i++)
			cout << "0";
	}
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104637569
今日推荐