poj—3348 凸包求点及面积

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input

4
0 0
0 101
75 0
75 101

Sample Output

151

题意:就是有养牛的人想要圈地养牛,给你一些树的点,求这些树围成的最大面积,该面积所能养牛的最大数量=面积/50,(水题),凸包模板一改一下下就可以了。。。。。。

思考:随意找一个点,从左至右遍历合适的点,然后从右至左往回便利一遍,找到顶点,不需要所有的点(树),然后求出其围成的面积即可。。。。。。

代码如下:

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int n,tot;
struct point {
    double x,y;
};
point a[10005],p[10005];

double dis(point A,point B) {                 //距离
    return sqrt((B.x-A.x)*(B.x-A.x)+(B.y-A.y)*(B.y-A.y));
}

double xmul(point A,point B,point C) {       //叉积,求顶点
    return (B.x-A.x)*(C.y-A.y)-(B.y-A.y)*(C.x-A.x);
}

int cmp(point A,point B) {                   //排序
    return (A.x<B.x||(A.x==B.x&&A.y<B.y));
}
double Area (point *p,int n) {                //面积 
    double area =0;
    for (int i=1; i<n -1; i++)
        area +=  xmul(p[i] ,p[i+1],p [0]);
    return fabs ( area /2);
}

int Andrew(point *p,int n,point *a) {                              //Andrew 算法
    sort(a,a+n,cmp);
    tot=0;
    for(int i=0; i<n; i++) {                                                    // 左至右遍历
        while(tot>1&&xmul(p[tot-2],p[tot-1],a[i])<0) tot--; //加共线的点!
        p[tot++]=a[i];
    }
    int k=tot;
    for(int i=n-2; i>=0; i--) {                                               //右至左遍历
        while(tot>k&&xmul(p[tot-2],p[tot-1],a[i])<0) tot--;
        p[tot++]=a[i];
    }
    if(n>1) tot--;
}
int main() {
    int n,i;
    scanf("%d",&n);
    for(i=0; i<n; i++) {
        scanf("%lf%lf",&a[i].x ,&a[i].y );
    }
    Andrew(p,n,a);
//    for(i=0; i<tot; i++) {                                          //查看P的内容
//        printf("%lf %lf\n",p[i].x ,p[i].y );
//    }
    int k=Area(p,tot);
    int q=k/50;
    printf("%d\n",q);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sf_yang35/article/details/81226440