poj 3348 Cows(凸包面积)

Cows

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10647   Accepted: 4661

Description

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input

4
0 0
0 101
75 0
75 101

Sample Output

151

Source

题意:给你一片树林,让你选择一些树围成一片区域使得区域最大,每只牛生活区域为50。求出最多能有多少只牛。

我们把凸包面积求出来然后直接除以50即可。

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
typedef long long ll;
#define maxn 100050
ll m;
struct point
{
	ll x,y;
}s[maxn],ch[maxn],re;

ll det(ll x1,ll y1,ll x2,ll y2)
{
	return x1*y2-y1*x2;
}

bool cmp(point a,point b)
{
	if(a.x==b.x) return a.y<b.y;
	return a.x<b.x;
}
void converxhall(point *p,ll n,point *ch)
{
	sort(p,p+n,cmp);
	m=0;
	for(ll i=0;i<n;i++)
	{
		while(m>1&&det(ch[m-1].x-ch[m-2].x,ch[m-1].y-ch[m-2].y,p[i].x-ch[m-2].x,p[i].y-ch[m-2].y)<0) m--;
		ch[m++]=p[i];
	}
	ll k=m;
	for(ll i=n-2;i>=0;i--)
	{
		while(m>k&&det(ch[m-1].x-ch[m-2].x,ch[m-1].y-ch[m-2].y,p[i].x-ch[m-2].x,p[i].y-ch[m-2].y)<0)
		{
			m--;
		}
		ch[m++]=p[i];
	}
	if(n>1) m--;
}

ll area(point *ch,ll m)
{
	ll s=0;
	for(int i=1;i<m-1;i++)
	{
		s+=det(ch[i].x-ch[0].x,ch[i].y-ch[0].y,ch[i+1].x-ch[0].x,ch[i+1].y-ch[0].y);
	}
	return s/2;
}
int main()
{
	ll n;
	cin>>n;
	for(ll i=0;i<n;i++)
	{
		cin>>s[i].x>>s[i].y;
	}
	converxhall(s,n,ch);
	cout<<area(ch,m)/50<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/81227712
今日推荐