POJ 2406 kmp循环应用

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

题意:

找出字符串中某一段子串的循环次数。。。。

ac代码:

#include<stdio.h>
#include<cstring>
const int MAXN=1e6+2;
int next[MAXN];
char s[MAXN];
int m;
void get_next()
{
    int i=1;
    int j=0;
    next[0]=0;
    while(i<m){
        if(s[i]==s[j])
        {
            next[i]=++j;
            i++;
        }
        else if(!j){
            i++;
        }
        else{
            j=next[j-1];
        }
    }
    i=m-j;
    if(m%i==0)
        printf("%d\n",m/i);
    else
        printf("1\n");
}

int main()
{
    while(scanf("%s",s)&&s[0]!='.')
    {
        m=strlen(s);
        get_next();
    }
    return 0;
}

报道。。。打卡

猜你喜欢

转载自blog.csdn.net/sf_yang35/article/details/81813354