upc 8835: Folding a Ribbon(模拟,折纸)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/winter2121/article/details/82344071

8835: Folding a Ribbon

时间限制: 1 Sec  内存限制: 128 MB
提交: 28  解决: 17
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Think of repetitively folding a very long and thin ribbon. First, the ribbon is spread out from left to right, then it is creased at its center, and one half of the ribbon is laid over the other. You can either fold it from the left to the right, picking up the left end of the ribbon and laying it over the right end, or from the right to the left, doing the same in the reverse direction. To fold the already folded ribbon, the whole layers of the ribbon are treated as one thicker ribbon, again from the left to the right or the reverse. 
After folding the ribbon a number of times, one of the layers of the ribbon is marked, and then the ribbon is completely unfolded restoring the original state. Many creases remain on the unfolded ribbon, and one certain part of the ribbon between two creases or a ribbon end should be found marked. Knowing which layer is marked and the position of the marked part when the ribbon is spread out, can you tell all the directions of the repeated folding, from the left or from the right? 
The figure below depicts the case of the first dataset of the sample input. 

输入

The input consists of at most 100 datasets, each being a line containing three integers. 
n i j
The three integers mean the following: The ribbon is folded n times in a certain order; then, the i-th layer of the folded ribbon, counted from the top, is marked; when the ribbon is unfolded completely restoring the original state, the marked part is the j-th part of the ribbon separated by creases, counted from the left. Both i and j are one-based, that is, the topmost layer is the layer 1 and the leftmost part is numbered 1. These integers satisfy 1 ≤ n ≤ 60, 1 ≤ i ≤ 2n, and 1 ≤ j ≤ 2n. 
The end of the input is indicated by a line with three zeros. 

输出

For each dataset, output one of the possible folding sequences that bring about the result specified in the dataset. 
The folding sequence should be given in one line consisting of n characters, each being either L or R. L means a folding from the left to the right, and R means from the right to the left. The folding operations are to be carried out in the order specified in the sequence. 

样例输入

3 3 2
12 578 2214
59 471605241352156968 431565444592236940
0 0 0

样例输出

LRR
RLLLRRRLRRLL
LRRRLRRLLRRRRLLLLRLLRRRLRRLLRLLLLLLRLRLLRLRLLLRLRLLRLLRRRLL

来源/分类

ICPC 2017 Japan Domestic 

[提交] [状态]

【题意】

对于一张纸,折叠n次后的层数为2的n次幂。先在给出折叠次数n,折叠起来后,从上面数第i层做一个标记,原样展开后标记在左数第j个,问这张纸是如何折起来的。

【分析】

先分析层数j,我们从折叠好的状态开始展开,会发现,如果标记在上半部分,那一定是从左边或者右边折上来的,如果在下半部分,那一定是折了一半压在上面。

这样分解得到一个关于每次折叠,标记所在部分是在上还是被压住的 序列。

然后正向分析,一次一次的折起来,根据上面得到的序列,就可以判断当前折叠的左右选择了。

【代码】

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll bit[62],n,x,y;
int mark[63];
int main()
{
    bit[0]=1;
    for(int i=1;i<62;i++)bit[i]=bit[i-1]<<1;
    while(scanf("%lld%lld%lld",&n,&x,&y),n)
    {
        for(int i=n;i;i--) //第i次折叠时,标记所在的那一半,是在上还是被压住
        {
            if(x>bit[i-1]>0) //被压住
            {
                mark[i]=1;
                x=x-bit[i-1];
            }
            else
            {
                mark[i]=0; //从上面掀开
                x=bit[i-1]+1-x;
            }
        }
        //现在知道了每次折叠,标记在上还是被压住
        for(int i=1;i<=n;i++)
        {
            if(y<=bit[n-i]) //标记在左
            {
                if(mark[i]) //标记需要被压住
                {
                    printf("R");
                    y=y;
                }
                else
                {
                    printf("L");
                    y=bit[n-i]-y+1;
                }
            }
            else
            {
                if(mark[i]) //标记需要被压住
                {
                    printf("L");
                    y=y-bit[n-i];
                }
                else
                {
                    printf("R");
                    y=bit[n-i+1]-y+1;
                }
            }
        }
        printf("\n");
    }
}

猜你喜欢

转载自blog.csdn.net/winter2121/article/details/82344071
UPC