@UPC8378 :Floating-Point Numbers (模拟, 浮点精度)

版权声明:岂曰无衣,与子同袍 https://blog.csdn.net/sizaif/article/details/82118943

Floating-Point Numbers

时间限制: 1 Sec  内存限制: 128 MB
提交: 45  解决: 25
[提交] [状态] [讨论版] [命题人:admin]

题目描述

In this problem, we consider floating-point number formats, data representation formats to approximate real numbers on computers.
Scientific notation is a method to express a number, frequently used for numbers too large or too small to be written tersely in usual decimal form. In scientific notation, all numbers are written in the form m × 10e. Here, m (called significand) is a number greater than or equal to 1 and less than 10, and e (called exponent) is an integer. For example, a number 13.5 is equal to 1.35×101, so we can express it in scientific notation with significand 1.35 and exponent 1.
As binary number representation is convenient on computers, let's consider binary scientific notation with base two, instead of ten. In binary scientific notation, all numbers are written in the form m × 2e. Since the base is two, m is limited to be less than 2. For example, 13.5 is equal to 1.6875×23, so we can express it in binary scientific notation with significand 1.6875 and exponent 3. The significand 1.6875 is equal to 1 + 1/2 + 1/8 + 1/16, which is 1.10112 in binary notation. Similarly, the exponent 3 can be expressed as 112 in binary notation.
A floating-point number expresses a number in binary scientific notation in finite number of bits. Although the accuracy of the significand and the range of the exponent are limited by the number of bits, we can express numbers in a wide range with reasonably high accuracy.
In this problem, we consider a 64-bit floating-point number format, simplified from one actually used widely, in which only those numbers greater than or equal to 1 can be expressed. Here, the first 12 bits are used for the exponent and the remaining 52 bits for the significand. Let's denote the 64 bits of a floating-point number by b64...b1. With e an unsigned binary integer (b64...b53)2, and with m a binary fraction represented by the remaining 52 bits plus one (1.b52...b1)2, the floating-point number represents the number m × 2e.
We show below the bit string of the representation of 13.5 in the format described above.

In floating-point addition operations, the results have to be approximated by numbers representable in floating-point format. Here, we assume that the approximation is by truncation. When the sum of two floating-point numbers a and b is expressed in binary scientific notation as a + b = m × 2e (1 ≤ m < 2, 0 ≤ e < 212), the result of addition operation on them will be a floating-point number with its first 12 bits representing e as an unsigned integer and the remaining 52 bits representing the first 52 bits of the binary fraction of m.
A disadvantage of this approximation method is that the approximation error accumulates easily. To verify this, let's make an experiment of adding a floating-point number many times, as in the pseudocode shown below. Here, s and a are floating-point numbers, and the results of individual addition are approximated as described above.
s := a
for n times {
    s := s + a
}
For a given floating-point number a and a number of repetitions n, compute the bits of the floating-point number s when the above pseudocode finishes.

输入

The input consists of at most 1000 datasets, each in the following format.

b52...b1 
n is the number of repetitions. (1 ≤ n ≤ 1018) For each i, bi is either 0 or 1. As for the floating-point number a in the pseudocode, the exponent is 0 and the significand is b52...b1.

The end of the input is indicated by a line containing a zero.

输出

For each dataset, the 64 bits of the floating-point number s after finishing the pseudocode should be output as a sequence of 64 digits, each being 0 or 1 in one line.

扫描二维码关注公众号,回复: 2908162 查看本文章

样例输入

1
0000000000000000000000000000000000000000000000000000
2
0000000000000000000000000000000000000000000000000000
3
0000000000000000000000000000000000000000000000000000
4
0000000000000000000000000000000000000000000000000000
7
1101000000000000000000000000000000000000000000000000
100
1100011010100001100111100101000111001001111100101011
123456789
1010101010101010101010101010101010101010101010101010
1000000000000000000
1111111111111111111111111111111111111111111111111111
0

样例输出

0000000000010000000000000000000000000000000000000000000000000000
0000000000011000000000000000000000000000000000000000000000000000
0000000000100000000000000000000000000000000000000000000000000000
0000000000100100000000000000000000000000000000000000000000000000
0000000000111101000000000000000000000000000000000000000000000000
0000000001110110011010111011100001101110110010001001010101111111
0000000110111000100001110101011001000111100001010011110101011000
0000001101010000000000000000000000000000000000000000000000000000

来源/分类

ICPC Japan 2018 Domestic 

题意: 

解释了 浮点运算的存储运算, 指数 12 位,  小数52 位

然后 求 n+1 个 小数a 相加,

然后保留中间的进位,误差 

然后输出 结果 用二进制,

思路:

研究了好几天, 研究代码研究了好几天....

可行的思路为 :  找到 进位的临界点,  在加一次a时产生进位, 其余是不进位的.

那么只需要考虑进位的情况,

进位时  指数位直接用int 存储,  进位一次++

小数用long long 存储.

[代码]

#include <stdio.h>
#include <bits/stdc++.h>
#define rep(i,a,n) for(int i=a;i<=n;i++)

typedef long long ll;
const int maxn =1e5+10;

using namespace std;
/*
*
* Author : Siz
*/

int main(int argc, char const *argv[])
{
	ll n;
	while(scanf("%lld",&n))
	{
		if(n==0)
			break;
		ll num = (1ll<<52);
		for(int i=51;i>=0;i--)
		{
			int bit;
			scanf("%1d",&bit);
			num|=(1ll*bit)<<i; // 输入字符串,转化成long long
		}
		ll res = 0 , Num = num; // res 指数部分 , Num 小数部分
		while(n >0)
		{

			ll temp = ( (1ll<<53)- Num + num-1)/num; // 多少次会产生进位
			if( temp > n) // 不够产生进位, 那么直接 加上结果 然后 break
			{
				Num += n*num;
				break;
			}
			else
			{
				Num += temp*num;
				res++ ;// 指数进位
				Num>>=1;
				num>>=1; // 指数进位, 则对应 小数 部分应该右移一位
				if( num < 1) break; // 优化, 当 num 全为0 时 在加也无意义
				n-=temp;
			}
		}
		for(int i=11;i>=0;i--) // 输出指数部分
			printf("%d", (1ll<<i)&res ? 1:0);
		for(int i=51;i>=0;i--) // 输出小数部分
			printf("%d", (1ll<<i)&Num ? 1:0);
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/sizaif/article/details/82118943