1072 Gas Station(30 分)

1072 Gas Station(30 分)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

重点就是去最短路径方法。

一个简单的 多源最短路径 Ford 还一个比较复杂的 Dijkstra

Ford:

#pragma warning(disable:4996)
#include <iostream>
#include <string>
#include <vector>
#include <set>
#define inf 0x7fffffff
using namespace std;
int deal(string s);
int map[1020][1020];
vector<int> vpoint;
void init() {
	for (int i = 0; i < 1020; ++i) {
		for (int j = 0; j < 1020; ++j) {
			if(i!=j) map[i][j] = inf;
		}
	}
}
int main() {
	int n, m, k, s;
	cin >> n >> m >> k >> s;
	string p1, p2;
	int dis;
	init();
	for (int i = 0; i < k; ++i) {
		cin >> p1 >> p2 >> dis;
		int i_p1 = deal(p1);
		int i_p2 = deal(p2);
		map[i_p1][i_p2] = dis;
		map[i_p2][i_p1] = dis;
	}
	for (int i = 1; i <= n; ++i) {
		vpoint.push_back(i);
	}
	for (int i = 1; i <= m; ++i) {
		vpoint.push_back(1000 + i);
	}
	for (int i = 0; i < vpoint.size(); ++i) {
		for (int j = 0; j < vpoint.size(); ++j) {
			for (int z = 0; z < vpoint.size(); ++z) {
				if (map[vpoint[i]][vpoint[z]] != inf && map[vpoint[z]][vpoint[j]] != inf && map[vpoint[i]][vpoint[j]] > map[vpoint[i]][vpoint[z]] + map[vpoint[z]][vpoint[j]]) {
					map[vpoint[i]][vpoint[j]] = map[vpoint[i]][vpoint[z]] + map[vpoint[z]][vpoint[j]];
				}
			}
		}
	}
	int mindis = -1, minpoint=0, minsum=-1;
	for (int i = 1001; i <= 1000+m; ++i) {
		bool f = 1;
		int mdis = 0x7fffffff;
		int sum = 0;
		for (int j = 1; j <=n; ++j) {
			if (map[i][j] != inf && map[i][j] <= s) {
				if (mdis > map[i][j]) {
					mdis = map[i][j];
				}
				sum += map[i][j];
			}
			else {
				f = 0;
				break;
			}
		}
		if (f) {
			if (mindis < mdis) {
				mindis = mdis;
				minpoint = i-1000;
				minsum = sum;
			}
			else if (mindis == mdis) {
				if (minsum > sum) {
					minpoint = i - 1000;
					minsum = sum;
				}
			}
		}

	}
	if (mindis != -1) {
		cout << 'G' << minpoint << endl;
		printf("%.1lf %.1lf", double(mindis), double(minsum) / n);
	}
	else {
		cout << "No Solution" << endl;
	}
	system("pause");
	return 0;
}
int deal(string s) {
	int res = 0;
	if (s[0] == 'G') {
		for(int i=1;i<s.size();++i){
			res *= 10;
			res += (s[i] - '0');
		}
		res += 1000;
	}
	else {
		for (int i = 0; i < s.size(); ++i) {
			res *= 10;
			res += (s[i] - '0');
		}
	}
	return res;
}

Dijkstra:

#pragma warning(disable:4996)
#include <iostream>
#include <string>
#include <vector>
#define inf 0x7fffffff
using namespace std;
int map[1020][1020];
int n, m, k, s;
void init();
int deal(string s);
void Dijkstra(int g);
int main() {
	cin >> n >> m >> k >> s;
	string p1, p2;
	int dis;
	init();
	for (int i = 0; i < k; ++i) {
		cin >> p1 >> p2 >> dis;
		int i_p1 = deal(p1);
		int i_p2 = deal(p2);
		map[i_p1][i_p2] = dis;
		map[i_p2][i_p1] = dis;
	}
	for (int i = 1; i <= m; ++i) {
		Dijkstra(1000 + i);
	}
	int mindis = -1, minpoint=0, minsum=-1;
	for (int i = 1001; i <= 1000+m; ++i) {
		bool f = 1;
		int mdis = 0x7fffffff;
		int sum = 0;
		for (int j = 1; j <=n; ++j) {
			if (map[i][j] != inf && map[i][j] <= s) {
				if (mdis > map[i][j]) {
					mdis = map[i][j];
				}
				sum += map[i][j];
			}
			else {
				f = 0;
				break;
			}
		}
		if (f) {
			if (mindis < mdis) {
				mindis = mdis;
				minpoint = i-1000;
				minsum = sum;
			}
			else if (mindis == mdis) {
				if (minsum > sum) {
					minpoint = i - 1000;
					minsum = sum;
				}
			}
		}
	}
	if (mindis != -1) {
		cout << 'G' << minpoint << endl;
		printf("%.1lf %.1lf", double(mindis), double(minsum) / n);
	}
	else {
		cout << "No Solution" << endl;
	}
	system("pause");
	return 0;
}
void Dijkstra(int g) {
	vector<int> vpoint; // 所有地点集合。
	for (int i = 1; i <= n; ++i) {
		vpoint.push_back(i);
	}
	for (int i = 1; i <= m; ++i) {
		vpoint.push_back(1000 + i);
	}

	vector<bool> vispoint(vpoint.size() + 1); //地点使用未使用的标志

	vector<int> vdis;  // 所有地点和g地点距离的集合。
	for (int i = 0; i < vpoint.size(); ++i) {
		vdis.push_back(map[g][vpoint[i]]);
	}
	while (1) {
		int mindis = inf, minpoint = 0;
		for (int i = 0; i < vdis.size(); ++i) {
			if (vispoint[i] == 0 && mindis > vdis[i]) {
				mindis = vdis[i];
				minpoint = i;
			}
		}
		vispoint[minpoint] = 1;
		int k = minpoint;
		minpoint = vpoint[minpoint];
		if (mindis == inf) break;
		for (int i = 0; i < vdis.size(); ++i) {
			if (map[minpoint][vpoint[i]] != inf && vdis[i] > vdis[k] + map[minpoint][vpoint[i]]) {
				vdis[i] = vdis[k] + map[minpoint][vpoint[i]];
			}
		}
	}
	for (int i = 0; i < vdis.size(); ++i) {
		map[g][vpoint[i]] = vdis[i];
	}
}
int deal(string s) {
	int res = 0;
	if (s[0] == 'G') {
		for(int i=1;i<s.size();++i){
			res *= 10;
			res += (s[i] - '0');
		}
		res += 1000;
	}
	else {
		for (int i = 0; i < s.size(); ++i) {
			res *= 10;
			res += (s[i] - '0');
		}
	}
	return res;
}
void init() {
	for (int i = 0; i < 1020; ++i) {
		for (int j = 0; j < 1020; ++j) {
			if (i != j) map[i][j] = inf;
		}
	}
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82347548