HDU - 6430 Problem E. TeaTree (启发式合并)(2018 Multi-University Training Contest 10 1005)

版权声明:Why is everything so heavy? https://blog.csdn.net/lzc504603913/article/details/81942314

Problem E. TeaTree

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 28    Accepted Submission(s): 11


 

Problem Description

Recently, TeaTree acquire new knoledge gcd (Greatest Common Divisor), now she want to test you.
As we know, TeaTree is a tree and her root is node 1, she have n nodes and n-1 edge, for each node i, it has it’s value v[i].
For every two nodes i and j (i is not equal to j), they will tell their Lowest Common Ancestors (LCA) a number : gcd(v[i],v[j]).
For each node, you have to calculate the max number that it heard. some definition:
In graph theory and computer science, the lowest common ancestor (LCA) of two nodes u and v in a tree is the lowest (deepest) node that has both u and v as descendants, where we define each node to be a descendant of itself.

 

Input

On the first line, there is a positive integer n, which describe the number of nodes.
Next line there are n-1 positive integers f[2] ,f[3], …, f[n], f[i] describe the father of node i on tree.
Next line there are n positive integers v[2] ,v[3], …, v[n], v[i] describe the value of node i.
n<=100000, f[i]<i, v[i]<=100000

 

Output

Your output should include n lines, for i-th line, output the max number that node i heard.
For the nodes who heard nothing, output -1.

 

Sample Input

 

4 1 1 3 4 1 6 9

 

Sample Output

 

2 -1 3 -1

 

Source

2018 Multi-University Training Contest 10

 

Recommend

chendu

题意:有一棵树,每对节点都会告诉他的最近公共祖先他们的GCD,求每一个节点知道的最大的GCD。

解题思路:先预处理,把每一个节点的所有因子预处理出来。然后对树深搜,回溯的时候记录这颗子树的所有因子,然后做启发式合并,小的并入大的。然后更新最大值即可。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <set>
#include <vector>
#include <map>
#include <stack>
#include <set>
#include <algorithm>
using namespace std;
typedef long long ll;
const int MAXN=200005;
const ll MOD=998244353;

vector<int> ch[100005];
int w[100005];
int ans[100005];
set<int> s[100005];
vector<int> yinzi[100005];

int merge(int x,int y){
    int res=-1;
    if(s[x].size()<s[y].size())
        swap(s[x],s[y]);
    for(set<int>::iterator it = s[y].begin();it!=s[y].end();it++){
        if(s[x].count(*it)){
            res=max(res,*it);
        }
        else{
            s[x].insert(*it);
        }
    }
    s[y].clear();
    return res;
}

void dfs(int x){
    for(int i=0;i<ch[x].size();i++){
        int j=ch[x][i];
        dfs(j);
        ans[x]=max(ans[x],merge(x,j));
    }
    for(int i=0;i<yinzi[w[x]].size();i++){
        if(s[x].count(yinzi[w[x]][i])){
            ans[x]=max(ans[x],yinzi[w[x]][i]);
        }
        else{
            s[x].insert(yinzi[w[x]][i]);
        }
    }
}

int main(){
    //预处理因子
    for(int i=1;i<=100000;i++)
        for(int j=i;j<=100000;j+=i)
            yinzi[j].push_back(i);
    int N;
    while(~scanf("%d",&N)){
        memset(ans,-1,sizeof(ans));
        int temp;
        for(int i=2;i<=N;i++){
            scanf("%d",&temp);
            ch[temp].push_back(i);
        }
        for(int i=1;i<=N;i++)
            scanf("%d",&w[i]);
        dfs(1);
        for(int i=1;i<=N;i++)
            printf("%d\n",ans[i]);
        for(int i=1;i<=N;i++){
            ch[i].clear();
            s[i].clear();
        }  
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/lzc504603913/article/details/81942314