Billboard(贴广告经典题)

版权声明:本文为博主原创文章,转载请说明出处。 https://blog.csdn.net/xianpingping/article/details/82179505

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28730    Accepted Submission(s): 11646


 

Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input

3 5 5

2

4

3

3

3

Sample Output

 

1 2 1 3 -1

Author

hhanger@zju

Source

HDOJ 2009 Summer Exercise(5)

Recommend

lcy   |   We have carefully selected several similar problems for you:  1698 1754 1542 1394 1828

题意:有一块大小h*w的公告牌,可以在上面贴广告,每张广告大小为1*wi,优先贴在高处,左边,如果可以贴,输出贴在了第几排,否则输出-1

思路:

该题利用线段树递归特点来求其最左边的大于等于a的位置。

线段树递归的特点是从祖先结点开始自顶向下递归,访问各个元素的顺序一定是从左到右, 并且在递归之后可以顺便维护区间结点的值。

利用这个特点, 我们可以直接查询到>=a的最左边的位置。该元素变成v - a,  然后顺便维护改变了的值。 所以该题就成了维护区间最大值的线段树题目。

代码:

#include<bits/stdc++.h>
using namespace std;
#define lson l,m,id*2
#define rson m+1,r,id*2+1
int h,w,n;
int maxx[200010*4];
void pushup(int id){
    maxx[id]=max(maxx[id*2],maxx[id*2+1]);
}
void build(int l,int r,int id){
    if(l==r)
    {
        maxx[id]=w; return;
    }
    int m=(l+r)/2;
    build(lson);
    build(rson);
    pushup(id);
}
int update(int w,int l,int r,int id){
    if(maxx[id]<w)
        return -1;
    if(l==r){
        if(maxx[id]>=w){
            maxx[id]-=w;
            return l;
        }
        else
            return -1;
    }
    int flag=-1;
    int m=(l+r)/2;
    flag=update(w,lson);
    if(flag<0){///在左区间找不到位置
        flag=update(w,rson);
    }
    pushup(id);
    return flag;
}
int main()
{
    while(scanf("%d%d%d",&h,&w,&n)!=EOF){
        if(h>n)
            h=n;
        build(1,h,1);
        int val;
        for(int i=1;i<=n;i++){
            scanf("%d",&val);
            printf("%d\n",update(val,1,h,1));
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/82179505
今日推荐