HDU - 1695 GCD —— 莫比乌斯反演

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Lngxling/article/details/81488488

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15143    Accepted Submission(s): 5793


 

Problem Description

Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.

 

 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.

 

 

Output

For each test case, print the number of choices. Use the format in the example.

 

 

Sample Input

 

2 1 3 1 5 1 1 11014 1 14409 9

 

 

Sample Output

 

Case 1: 9 Case 2: 736427

Hint

For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

题意:

求1<=x<=b,1<=y<=d中满足gcd(x,y)=k的对数

思路:

设n=b/k,m=d/k,

要求gcd(x,y)=k,即求满足1<=x<=n,1<=y<=m中gcd(x,y)=1的对数,

设f(d)为满足gcd(x,y)=t的对数,

则可以构造F(d)为满足gcd(x,y)%d=0的对数,那么F(d)=(n/d)*(m/d),

由莫比乌斯反演,可以通过构造的F函数求出f函数,

因为(a,b)和(b,a)不同时计算,所以要再减去重复的部分。

要注意特判k=0的时候,否则会RE....

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <cmath>
#include <vector>
#include <bitset>
#define max_ 1100000
#define inf 0x3f3f3f3f
#define ll long long
#define les 1e-8
#define mod 364875103
using namespace std;
bool vis[max_];
int prime[max_];
int pl=0;
ll mu[max_];
int a,b,c,d,k;
void getmu()
{
    mu[1]=1;
    for(int i=2;i<max_;i++)
    {
        if(vis[i]==false)
        {
            prime[++pl]=i;
            mu[i]=-1;
        }
        for(int j=1;j<=pl&&prime[j]*i<max_;j++)
        {
            vis[prime[j]*i]=true;
            if(i%prime[j]==0)
            {
                mu[i*prime[j]]=0;
                break;
            }
            else
            mu[prime[j]*i]=-mu[i];
        }
    }
}
int main(int argc, char const *argv[]) {
    getmu();
    int t;
    scanf("%d",&t);
    for(int r=1;r<=t;r++)
    {
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
        if(k==0)
        {
            printf("Case %d: 0\n",r );
            continue;
        }
        int n=b/k;
        int m=d/k;
        if(n>m)
        swap(n,m);
        ll ans1=0,ans2=0;
        for(int i=1;i<=n;i++)
        {
            ans1+=mu[i]*(n/i)*(m/i);
            ans2+=mu[i]*(n/i)*(n/i);
        }
        printf("Case %d: %lld\n",r,ans1-ans2/2);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Lngxling/article/details/81488488