pta--1027 Colors in Mars(20 分)(进制&&思维)

1027 Colors in Mars(20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

【分析】

题意:给你3个十进制数,令其转换为13进制并输出,如果不足两位则左补0;

思路:因为题上给了数字的范围,因此每个数转换为13进制后最多为两位,那么!!!就简单了很多!即a/13 和 a%13两个数!!!就是这么简单!我一开始还写了那么多的代码。。。太菜了太菜了....

#include<iostream>
#include<cstdio>
using namespace std;
int main() {
    char c[14] = {"0123456789ABC"};
    printf("#");
    for(int i = 0; i < 3; i++) {
        int num;
        scanf("%d", &num);
        printf("%c%c", c[num/13], c[num%13]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38735931/article/details/82154097