1018 Public Bike Management (30)(30 分)(C++)

1018 Public Bike Management (30)(30 分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

\ Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S~3~, we have 2 different shortest paths:

1. PBMC -> S~1~ -> S~3~. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S~1~ and then take 5 bikes to S~3~, so that both stations will be in perfect conditions.

2. PBMC -> S~2~ -> S~3~. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C~max~ (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; S~p~, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C~i~ (i=1,...N) where each C~i~ is the current number of bikes at S~i~ respectively. Then M lines follow, each contains 3 numbers: S~i~, S~j~, and T~ij~ which describe the time T~ij~ taken to move betwen stations S~i~ and S~j~. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0-&gtS~1~->...-&gtS~p~. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S~p~ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

解题思路:作为一个管理员,现给定一个终点,你要选择最短路径到这个点,很明显是Dijsktra的使用。但是重点在下面,同时这一路上我们要把所有节点的权值都调节至最佳。另一方面,最短路径不一定唯一,因此我们用pre数组先存储所有路径,再用DFS遍历,选择最后带回的车辆最少的那条路。

#include<iostream>
#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;
const int inf=999999999;
std::vector<int> pre[505];
int w[505],e[505][505],dis[505];
bool visit[505];
int maxnum,n,End,m,perfect;
std::vector<int> temppath,resultpath;
int tempsend=0,tempback=0,resultsend=inf,resultback=inf;
bool flag;
void dfs(int index){
    if(index==0){
		tempsend=0;tempback=0;
        for(int i=temppath.size()-1;i>=0;i--){
             tempback+=(w[temppath[i]]-perfect);
              if(tempback<0){
                  tempsend-=tempback;
                  tempback=0;
                }
        }
        if(tempsend<resultsend){
            resultback=tempback;
            resultsend=tempsend;
			      resultpath=temppath;
        }
        else if(tempsend==resultsend&&tempback<resultback){
            resultback=tempback;
            resultsend=tempsend;
			      resultpath=temppath;
        }
        return;
    }
    temppath.push_back(index);
    for(int i=0;i<pre[index].size();i++)
        dfs(pre[index][i]);
    temppath.pop_back();
}
int main(){
    fill(e[0],e[0]+505*505,inf);
    fill(dis,dis+505*505,inf);
    scanf("%d %d %d %d",&maxnum,&n,&End,&m);
    perfect=maxnum/2;
    for(int i=1;i<=n;i++)
        scanf("%d",&w[i]);
    for(int i=0;i<m;i++){
        int a,b,temp;
        scanf("%d %d %d",&a,&b,&temp);
        e[a][b]=temp;e[b][a]=temp;
    }
    w[0]=0;dis[0]=0;
    for(int i=0;i<=n;i++){
        int u=-1,min=inf;
        for(int j=0;j<=n;j++){
            if(dis[j]<min&&visit[j]==false){
                u=j;
                min=dis[i];
            }
        }
        if(u==-1)
            break;
        visit[u]=true;
        for(int v=0;v<=n;v++){
            if(visit[v]==false&&e[u][v]!=inf){
                if(dis[u]+e[u][v]<dis[v]){
                    pre[v].clear();
                    pre[v].push_back(u);
                    dis[v]=dis[u]+e[u][v];
                }
                else if(dis[u]+e[u][v]==dis[v])
                    pre[v].push_back(u);
            }
        }
    }
    if(w[End]==0)
        flag=0;
    else
        flag=1;
    dfs(End);
    printf("%d 0",resultsend);
    for(int i=resultpath.size()-1;i>=0;i--)
        printf("->%d",resultpath[i]);
    printf(" %d",resultback);
    system("pause");
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/81989318