Trees on the level

Trees on the level

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. 

This problem involves building and traversing binary trees. 
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes. 

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. 

For example, a level order traversal of the tree 

 
is: 5, 4, 8, 11, 13, 4, 7, 2, 1. 

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once. 
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

题解:输入一棵二叉树,你的任务是按从上到下、从左到右的顺序输出各个结点的值。每个结点都按照从根结点到它的移动序列给出(L表示左,R表示右)。在输入中,每个结点的左括号和右括号之间没有空格,相邻结点之间用一个空格隔开。每棵树的输入用一对空括号“()”结束(这对括号本身不代表一个结点)。

注意,如果从根到某个叶结点的路径上有的结点没有在输入中给出,或者给出超过一次,应当输出-1。结点个数不超过256。

样例输入:

(11,LL) (7,LLL) (8,R) (5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) () 
(3,L) (4,R) ()

样例输出:

5 4 8 11 13 4 7 2 1 
not complete

代码:

#include<cstdio>
#include<cstring>
#include<map>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
	int x,y;
	string s;
}e[1010];
bool cmp(node a,node b)
{
	if(a.y==b.y)
	 return a.s<b.s;
	else 
	  return a.y<b.y;
}
int main()
{
	int n=0,flag=0;
	string str;
	map<string,int>v;
	while(cin>>str)
	{
		int i,num[500];
		if(str=="()")
		{
			sort(e,e+n,cmp);
			if(flag||e[0].y!=0)
			  printf("not complete\n");
			else
			{
				for(i=0;i<n;i++)
				{
					if(e[i].y>0)
					{
						string s;
						int l=e[i].s.size();
						for(int j=0;j<l-1;j++)
						  s+=e[i].s[j];
						if(v[s]!=1)
						 {
						 	flag=1;
						 	break;
						 }	 
					}
					num[i]=e[i].x;
				}
				if(flag)
				printf("not complete\n");
				else
				{
					for(i=0;i<n;i++)
					{
						if(i<n-1)
			              printf("%d ",num[i]);
						 else
						  printf("%d\n",num[i]);			
					}
				}
			}
			n=flag=0;
			v.clear();
			continue;
		}
		int x=0,l=str.size();
		for(i=1;i<l;i++)
		{
			if(str[i]==',')
			  break;
			x=x*10+str[i]-'0';
		}
		e[n].x=x;
		x=0;
		e[n].s.clear();
		for(i=i+1;i<l;i++)
		{
			if(str[i]==')')
			 break;
			 x++;
			e[n].s+=str[i];
		}
		v[e[n].s]++;
		if(v[e[n].s]>=2)
		 flag=1;
		 e[n].y=x;
		 n++;
	}
}

猜你喜欢

转载自blog.csdn.net/zhengde152/article/details/82084498