HDU ACM1029——Ignatius and the Princess IV

Ignatius and the Princess IV

Problem Description

“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.

Can you find the special integer for Ignatius?

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output

For each test case, you have to output only one line which contains the special number you have found.

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output

3
5
1

题目大意:给你n个数字(n为奇数),让你找出出现次数大于一半的数字。
这是一道水题,不过水题也有水题的思路。
刚开始我是这样做的:

#include<stdio.h>
int a[1000000];
int main(){
    int n,i,j,count;
    while(scanf("%d",&n)!=EOF){
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=0;i<n;i++){   /*从第一个数开始不断找相同的数*/  
            count=0;    /*计数器*/ 
            for(j=0;j<n;j++){
                if(a[i]==a[j]){
                    count++;
                }
                if(count>=(n+1)/2){     /*超过一半直接输出*/                
                    printf("%d\n",a[i]);
                    break;                  
                }
            }
            if(count>=(n+1)/2)break;
        }
        if(count<(n+1)/2)break;
    }
}

完全是莽过去的,时间复杂度为O(n^2)还好n不大不会超时。现在再重新看这道题,其实还有更省时的方法:

扫描二维码关注公众号,回复: 2930903 查看本文章
#include<stdio.h>
int main()
{
    int n,a,b,i;
    while(scanf("%d",&n)!=EOF){
        int con=1;  /*计数器*/ 
        scanf("%d",&b);
        for(i=1;i<n;i++){
            scanf("%d",&a);
            if(a==b)con++;   
            else con--;
            if(con==0){ /*计数器为零则重新配对*/ 
                scanf("%d",&b);
                con++;
                i++;
            }
        }
        printf("%d\n",b);    
    }
    return 0;
}

代码更加简单明了,大体思路:一一配对,因为找的那个数比所有其他数加起来个数还多,所以即使最坏的情况找的那个数与其他数都抵消了,也还剩下一个要找的数,所以用相同加一,不同抵消的思路做时间复杂度为O(n)。

猜你喜欢

转载自blog.csdn.net/BarisGuo/article/details/82113989