HDU 1029 Ignatius and the Princess IV(水题)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 42648    Accepted Submission(s): 18628

Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.
"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.
"But what is the characteristic of the special integer?" Ignatius asks.
"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.
Can you find the special integer for Ignatius?

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output

For each test case, you have to output only one line which contains the special number you have found.

Sample Input

5

1 3 2 3 3

11

1 1 1 1 1 5 5 5 5 5 5

7

1 1 1 1 1 1 1

Sample Output

3

5

1

题解:这道题目很简单直接定义一个存储a数组内元素出现的个数的数组cont即可。

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int a[1000005];
int cont[1000005];
int main()
{
    int n,m;
    while(scanf("%d",&n)!=EOF)
    {
        memset(cont,0,sizeof(cont));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            cont[a[i]]++;
            if(cont[a[i]]>=(n+1)/2)m=a[i];
        }
        printf("%d\n",m);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sinat_41233888/article/details/81215005