HDU-2052 Picture

Problem Description

Give you the width and height of the rectangle,darw it.

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output

For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input

3 2

Sample Output

+---+

|     |

|     |

+---+

简单的模拟题。

代码:

#include <stdio.h>
int main()
{
	int n,m,i,j;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		printf("+");
		for(i=0;i<n;i++)
			printf("-");
		printf("+");
		printf("\n");
		for(j=0;j<m;j++)
		{
			printf("|");
			for(i=0;i<n;i++)
				printf(" ");
			printf("|");
			printf("\n");
		}
		printf("+");
		for(i=0;i<n;i++)
			printf("-");
		printf("+\n\n");
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/82012964
今日推荐