Floating-Point Numbers

Floating-point numbers are represented differently in computers than integers. That is why a 32-bit
floating-point number can represent values in the magnitude of 1038 while a 32-bit integer can only
represent values as high as 232
.
Although there are variations in the ways floating-point numbers are stored in Computers, in this
problem we will assume that floating-point numbers are stored in the following way:
Floating-point numbers have two parts mantissa and exponent. M-bits are allotted for mantissa
and E bits are allotted for exponent. There is also one bit that denotes the sign of number (If this
bit is 0 then the number is positive and if it is 1 then the number is negative) and another bit that
denotes the sign of exponent (If this bit is 0 then exponent is positive otherwise negative). The value of
mantissa and exponent together make the value of the floating-point number. If the value of mantissa
is m then it maintains the constraints 1
2 ≤ m < 1. The left most digit of mantissa must always be 1 to
maintain the constraint 1
2 ≤ m < 1. So this bit is not stored as it is always 1. So the bits in mantissa
actually denote the digits at the right side of decimal point of a binary number (Excluding the digit
just to the right of decimal point)
In the figure above we can see a floating-point number where M = 8 and E = 6. The largest value
this floating-point number can represent is (in binary) 0.1111111112 ×2
1111112
. The decimal equivalent
to this number is: 0.998046875 × 2
63 = 920535763834529382410. Given the maximum possible value
represented by a certain floating point type, you will have to find how many bits are allotted for
mantissa (M) and how many bits are allotted for exponent (E) in that certain type.
Input
The input file contains around 300 line of input. Each line contains a floating-point number F that
denotes the maximum value that can be represented by a certain floating-point type. The floating point
number is expressed in decimal exponent format. So a number AeB actually denotes the value A×10B.
A line containing ‘0e0’ terminates input. The value of A will satisfy the constraint 0 < A < 10 and
will have exactly 15 digits after the decimal point.
Output
For each line of input produce one line of output. This line contains the value of M and E. You can
assume that each of the inputs (except the last one) has a possible and unique solution. You can also
assume that inputs will be such that the value of M and E will follow the constraints: 9 ≥ M ≥ 0 and
30 ≥ E ≥ 1. Also there is no need to assume that (M + E + 2) will be a multiple of 8.
Sample Input
5.699141892149156e76
9.205357638345294e18
0e0
Sample Output
5 8
8 6
代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
char s[77];
int main()
{
double a;
long long int b;
int m,e,i;
while(scanf("%s",s)&&strcmp(s,“0e0”)!=0)
{
for(i=0;i<strlen(s);i++)
if(s[i]==‘e’)
s[i]=’ ';
sscanf(s,"%lf %lld",&a,&b);
for(m=0;m<=9;m++)
{
e=round(log10((log10(a)+b-log10(pow(2,m+1)-1)+(m+1)*log10(2))/log10(2)+1)/log10(2));
if(e>30||e<1)
continue;
if(fabs(log10(pow(2,m+1)-1)-(m+1)*log10(2)+(pow(2,e)-1)*log10(2)-log10(a)-b)<1e-4)
{
printf("%d %d\n",m,e);
break;
}
}
memset(s,0,sizeof(s));
}
return 0;
}
学习

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/86294313