PAT-1040 Longest Symmetric String

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/eric4784510/article/details/82080770

1040 Longest Symmetric String(25 分)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

    最长回文子串,经典动态规划题型之一,dp[i][j]表示数组[i,j]范围内子串是否是回文串,起点为len为1,2,取len=3,4,....str.len()完善状态即可,找到使dp[i][j]==true的(j-i)的最大值。

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
bool dp[1005][1005]={0};
int main(){
	char c[1100];
	cin.getline(c,1006);
	int len=strlen(c);
	dp[0][0]=true;
	for(int i=1;i<len;i++){
		dp[i][i]=true;
		if(c[i]==c[i-1]){
			dp[i-1][i]=true;
		}
	}
	for(int tlen=3;tlen<=len;tlen++){
		for(int j=0;j+tlen-1<len;j++){
			if(c[j]==c[j+tlen-1]&&dp[j+1][j+tlen-2]==true)
				dp[j][j+tlen-1]=true;
			else
				dp[j][j+tlen-1]=false;
		}
	}

	int mi=0,mj=0;
	for(int i=0;i<len;i++){
		for(int j=i;j<len;j++){
			if(dp[i][j]==true&&j-i>mj-mi){
				mj=j;mi=i;
			}
		}
	}
	printf("%d",mj-mi+1);

	return 0;
}

猜你喜欢

转载自blog.csdn.net/eric4784510/article/details/82080770