POJ2027 ZOJ2201 UVALive3077 No Brainer【水题】

No Brainer

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 28441   Accepted: 18710

Description

Zombies love to eat brains. Yum.

Input

The first line contains a single integer n indicating the number of data sets. 

The following n lines each represent a data set. Each data set will be formatted according to the following description: 

A single data set consists of a line "X Y", where X is the number of brains the zombie eats and Y is the number of brains the zombie requires to stay alive. 

Output

For each data set, there will be exactly one line of output. This line will be "MMM BRAINS" if the number of brains the zombie eats is greater than or equal to the number of brains the zombie requires to stay alive. Otherwise, the line will be "NO BRAINS".

Sample Input

3
4 5
3 3
4 3

Sample Output

NO BRAINS
MMM BRAINS
MMM BRAINS

Source

South Central USA 2004

Regionals 2004 >> North America - South Central USA

问题链接POJ2027 ZOJ2201 UVALive3077 No Brainer

问题描述:(略)

问题分析

  大水题,不解释。就用C语言程序来实现吧!

程序说明:(略)

参考链接:(略)

题记:(略)

AC的C语言程序如下:

/* POJ2027 ZOJ2201 UVALive3077 No Brainer */

#include <stdio.h>

int main(void)
{
    int n;
    scanf("%d", &n);
    while(n--) {
        int a, b;
        scanf("%d%d", &a, &b);
        printf("%s\n", a < b ? "NO BRAINS" : "MMM BRAINS");
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/81843677
今日推荐