HUD1358周期kmp

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3

aaa

12

aabaabaabaab

0

Sample Output

Test case #1

2 2

3 3

Test case #2

2 2

6 2

9 3

12 4

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1358

#include<stdio.h>
#include<string.h>
#define N 1000005
char str[N];
int next[N];
void getnext()//这里不能用优化版kmp算法,不然周期循环会漏掉的
{
    int i=0,j=-1;
    memset(next,0,sizeof(next));
    next[0]=-1;
    while(str[i])
    {
        if(j==-1||str[i]==str[j])
        {
            i++;j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
void kmp()
{
    int i,len=strlen(str);
    for(i=2;i<=len;i++)
    {
        int t=i-next[i];
        if(i%t==0&&i/t>1)
            printf("%d %d\n",i,i/t);
    }
}
int main()
{
    int n;
    int cnt=1;
    while(~scanf("%d",&n),n)
    {
        scanf("%s",&str);
        getnext();
        printf("Test case #%d\n",cnt++);
        kmp();
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/salmonwilliam/article/details/81836633
今日推荐