hdu1509 优先队列

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9171    Accepted Submission(s): 3821


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 
Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 
Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 
Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
 
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!
 
直接优先队列+结构。注意的是,同一消息可能出现多次,因此要对每条消息按出现顺序标记一下
 
 
#include<iostream>
#include<queue>
#include<string.h>
#include<stdio.h>
using namespace std;
struct node
{
    char name[500];
    int num;//指令编号
    int rank;//第一优先级
    int val;//第二优先级(同一消息可能出现多次,因此需要按输入顺序重新编号)
}p;
bool operator <(const node &x,const node &y)//重载小于运算符
{
    if(x.rank==y.rank)
        return x.val>y.val;//第二优先级越大越小
    else
        return x.rank>y.rank;//越大优先级越小
}
int main()
{
    char str[5];
    int k=0;
    priority_queue<node>q;
    while(scanf("%s",str)!=EOF)
    {
        if(strcmp(str,"PUT")==0)
        {
            scanf("%s %d %d",p.name,&p.num,&p.rank);
            p.val=++k;
            q.push(p);
        }
        else
        {
            if(q.empty())
                printf("EMPTY QUEUE!\n");
            else
            {
                p=q.top();
                q.pop();
                printf("%s %d\n",p.name,p.num);
            }
        }
    }   
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/-citywall123/p/9504151.html