Atcoder A - Task Scheduling Problem

A - Task Scheduling Problem


Time limit : 2sec / Memory limit : 1024MB

Score : 100 points

Problem Statement

You have three tasks, all of which need to be completed.

First, you can complete any one task at cost 0.

Then, just after completing the i-th task, you can complete the j-th task at cost |AjAi|.

Here, |x| denotes the absolute value of x.

Find the minimum total cost required to complete all the task.

Constraints

  • All values in input are integers.
  • 1≤A1,A2,A3≤100

Input

Input is given from Standard Input in the following format:

A1 A2 A3

Output

Print the minimum total cost required to complete all the task.


Sample Input 1

Copy

1 6 3

Sample Output 1

Copy

5

When the tasks are completed in the following order, the total cost will be 5, which is the minimum:

  • Complete the first task at cost 0.
  • Complete the third task at cost 2.
  • Complete the second task at cost 3.

Sample Input 2

Copy

11 5 5

Sample Output 2

Copy

6

Sample Input 3

Copy

100 100 100

Sample Output 3

Copy

0
#include <stdio.h>//之前想多了,但是最后发现只要找最大和最小就可以。。
const int MAX = 100 + 10 ;
int main()
{
	int a[3];
	int i=0;
	scanf("%d",&a[0]);
	scanf("%d",&a[1]);
	scanf("%d",&a[2]);
	for(i=0;i<3;i++)//这里写了一段冒泡排序。。因为当时懒得想别的算法。。
	{
		int j=0;
		for(j=0;j<2-i;j++)
		{
			if(a[j]>a[j+1])
			{
				int t=a[j+1];
				a[j+1]=a[j];
				a[j]=t;
			}
		}
	}//肯定有别的更便捷的算法的,我就是个小渣渣。。骚套路什么的还是算了吧
	printf("%d",a[2]-a[0]);
}

猜你喜欢

转载自blog.csdn.net/Jet_KILL/article/details/81157256