A Magic Lamp HDU - 3183 -csdn博客


Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams.
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it.
Sample Input
178543 4
1000001 1
100001 2
12345 2
54321 2
Sample Output
13
1
0
123
321


  • 题意:给你一个大数,在这个数中删除m个数后,求得剩余数的最小可能值

  • 解题思路:我刚开始做的时候想的是直接在这个数中删掉m个数,然后就是删掉的策略问题。一直W。最后看了别人题解都是写的从中找出n-m个剩余的数,然后仔细想过后发现原来的解法存在问题,~~(>_<)~~

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string s;
    int n;
    while(cin>>s>>n)
    {
        //debug;
        int m=s.size()-n;
        string ans;
        int l=0;
        bool f=false;
        for(int i=n;i<s.size();i++)

        {
            int k=10;
            for(int j=l;j<=i;j++)
            {
                if(s[j]-'0'<k){
                    l=j+1;k=s[j]-'0';
                }
            }
            if(k)f=true;
            if(f){ans+=(k+'0');}
        }
        //cout<<ans<<endl;
        if(!ans.size())printf("0\n");
        else cout<<ans<<endl;
    }   
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38701476/article/details/80807591