[ PAT-A ] 1027 Colors in Mars (C++)

题目描述

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input
Each input file contains one test case which occupies a line containing the three decimal color values.

Output
For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

Sample Input
15 43 71

Sample Output
#123456


解题思路

题目大意
进制转换.给定三个十进制数,将其转换为13进制数
思路
因为题目本身给的十进制数和要求转的13进制数都不超过两位,所以可以用数组代替写一个进制转换模块


代码设计
//AC代码
//zhicheng
#include<cstdio>
#include<iostream>
using namespace std;
//zhicheng
//August 10,2018
int main()
{
    char c[14]={"0123456789ABC"};
    printf("#");
    for(int i=0;i<3;i++)
    {
        int rgb;
        scanf("%d",&rgb);
        printf("%c%c",c[rgb/13],c[rgb%13]);
    }
    printf("\n");
    return 0;
}


有关PAT (Basic Level) 的更多内容可以关注 ——> PAT-B题解


有关PAT (Advanced Level) 的更多内容可以关注 ——> PAT-A题解

铺子日常更新,如有错误请指正
传送门:代码链接 PTA题目链接 PAT-A题解

猜你喜欢

转载自blog.csdn.net/S_zhicheng27/article/details/81561820