A funny Game

Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 10 6) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)


Figure 1


Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)

Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, if Alice win the game,output "Alice", otherwise output "Bob".

Sample Input

1
2
3
0

Sample Output

Alice
Alice
Bob

题意:有一个n个硬币摆成的环,Alice和Bob每次从里面取出一个或两个硬币,Alice先手,谁取到最后一个硬币谁就赢。

对这个问题后手可以采取的策略是 先手取完第一次以后,把剩下的链平均分为两份(奇数取一个,偶数取两个),然后不管先手接下来怎么取都和她取相同数量的硬币(从另一份中取),最后取的一定是后手。

当然了,如果先手第一次取的时候就能取完,那么先手就赢了。(n<=2)

#include <iostream>
using namespace std;

int main()
{
	int n;
	while (cin>>n)
	{
		if (n==0) break;
		if ( n<=2 ) cout<<"Alice\n";
		else cout<<"Bob\n";
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41703679/article/details/81452963