G - Throw nails

来源hde4393

The annual school bicycle contest started. ZL is a student in this school. He is so boring because he can't ride a bike!! So he decided to interfere with the contest. He has got the players' information by previous contest video. A player can run F meters the first second, and then can run S meters every second.
Each player has a single straight runway. And ZL will throw a nail every second end to the farthest player's runway. After the "BOOM", this player will be eliminated. If more then one players are NO.1, he always choose the player who has the smallest ID.

Input

In the first line there is an integer T (T <= 20), indicates the number of test cases.
In each case, the first line contains one integer n (1 <= n <= 50000), which is the number of the players.
Then n lines follow, each contains two integers Fi(0 <= Fi <= 500), Si (0 < Si <= 100) of the ith player. Fi is the way can be run in first second and Si is the speed after one second .i is the player's ID start from 1.

Hint

Huge input, scanf is recommended.
Huge output, printf is recommended.

Output

For each case, the output in the first line is "Case #c:".
c is the case number start from 1.
The second line output n number, separated by a space. The ith number is the player's ID who will be eliminated in ith second end.

Sample Input

2
3
100 1
100 2
3 100
5
1 1
2 2
3 3
4 1
3 4

Sample Output

Case #1:
1 3 2
Case #2:
4 5 3 2 1

Hint

The first case:

1st Second end
Player1 100m (BOOM!!)
Player2 100m
Player3 3m

2nd Second end
Player2 102m
Player3 103m (BOOM!!)

3rd Second end
Player2 104m (BOOM!!)

因为只有500初始位置,先排500次,剩下的按速度,按初始位置,按id排就可以

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include <iomanip>
#include<cmath>
#include<float.h> 
#include<string.h>
#include<algorithm>
#define sf scanf
#define pf printf
#define scf(x) scanf("%d",&x)
#define scff(x,y) scanf("%d%d",&x,&y)
#define prf(x) printf("%d\n",x) 
#define mm(x,b) memset((x),(b),sizeof(x))
#include<vector>
#include<queue>
#include<map>
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=a;i>=n;i--)
typedef long long ll;
const ll mod=1e9+7;
const double eps=1e-8;
const int inf=0x3f3f3f3f;
using namespace std;
const double pi=acos(-1.0);
const int N=3e2+10;
struct peo
{
    int speed,pos,id,visit;
}a[50005];
bool cmp(peo a,peo b)
{
    if(a.visit!=b.visit)
    return a.visit>b.visit;
    if(a.speed!=b.speed)
    return a.speed>b.speed;
    if(a.pos!=b.pos)
    return a.pos>b.pos;
    return a.id<b.id;
}
void solve(int cas,int n)
{
    pf("Case #%d:\n",cas);
    int ans=0,Max=0;
    rep(i,0,min(n,502))
    {
        Max=0;
        rep(j,0,n)
        {
            if(a[j].visit==0)
            if(a[j].pos+a[j].speed*i>Max)
            {
                Max=a[j].pos+a[j].speed*i;
                ans=j;
            }
        }
        if(i==0)
        pf("%d",a[ans].id);
        else
        pf(" %d",a[ans].id);
        a[ans].visit=1;
    }
    if(n<=502)
    {
        pf("\n");return;
    }
    sort(a,a+n,cmp);
    rep(i,502,n)
        pf(" %d",a[i].id);  
    pf("\n");
}

int main()
{
    int re,cas=1;;
    scf(re);
    while(re--)
    {
        int id=1,n;
        scf(n);
        rep(i,0,n)
        {
            a[i].visit=0;
            a[i].id=id++;
            scff(a[i].pos,a[i].speed);
        }
        solve(cas++,n);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/wzl19981116/p/9499091.html
今日推荐