hdu6393Traffic Network in Numazu【树状数组】【LCA】

Traffic Network in Numazu

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 677    Accepted Submission(s): 269


 

Problem Description

Chika is elected mayor of Numazu. She needs to manage the traffic in this city. To manage the traffic is too hard for her. So she needs your help. 
You are given the map of the city —— an undirected connected weighted graph with N nodes and N edges, and you have to finish Q missions. Each mission consists of 3 integers OP, X and Y. 
When OP=0, you need to modify the weight of the Xth edge to Y. 
When OP=1, you need to calculate the length of the shortest path from node X to node Y.

 

Input

The first line contains a single integer T, the number of test cases. 
Each test case starts with a line containing two integers N and Q, the number of nodes (and edges) and the number of queries. (3≤N≤105)(1≤Q≤105) 
Each of the following N lines contain the description of the edges. The ith line represents the ith edge, which contains 3 space-separated integers ui, vi, and wi. This means that there is an undirected edge between nodes ui and vi, with a weight of wi. (1≤ui,vi≤N)(1≤wi≤105) 
Then Q lines follow, the ith line contains 3 integers OP, X and Y. The meaning has been described above.(0≤OP≤1)(1≤X≤105)(1≤Y≤105) 
It is guaranteed that the graph contains no self loops or multiple edges.

 

Output

For each test case, and for each mission whose OP=1, print one line containing one integer, the length of the shortest path between X and Y.

 

Sample Input

 

2 5 5 1 2 3 2 3 5 2 4 5 2 5 1 4 3 3 0 1 5 1 3 2 1 5 4 0 5 4 1 5 1 5 3 1 2 3 1 3 2 3 4 4 4 5 5 2 5 5 0 1 3 0 4 1 1 1 4

 

Sample Output

 

5 6 6 6

 

Source

2018 Multi-University Training Contest 7

 

Recommend

chendu   |   We have carefully selected several similar problems for you:  6408 6407 6406 6405 6404 

 

看题目就觉得是会是一道线段树单点修改区间查询

但是题目是一个图 n个点n条边

于是czc提出去掉一条边 看了题解果然是这样子

  • 先把环中的任意一条边去除,边连接的两点记为r1,r2
  • 每次查询的时候,x与y之间的距离有三个:(1)去除边后树上的最短距离;(2)x->r1->r2->y;(3) x->r2->r1->y。取三个值中的最小值即可

树状数组和线段树是非常相近的 今天去查了一下区别

树状数组可以解决的题目线段树都一定能解决,但是反之不一定

也就是说线段树的功能更强大一点

但是树状数组写起来比较方便,而且常数比线段树好,速度快

这道题因为是问区间和 所以树状数组够用了

这道题还有一个知识点是LCA

树上的最短路可以用LCA来求 Tarjan算法 =  dfs序+并查集的find


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stack>
#define inf 1e18
using namespace std;

int t, n, q;
const int maxn = 100050;
struct edge{
    int v, nxt, val;
}e[maxn * 2];
int head[maxn], tot;

void addedge(int x, int y, int d)
{
    e[++tot] = (edge){y, head[x], d};
    head[x] = tot;
}

long long sum[maxn];
void add(int x, int val)
{
    while(x <= n){
        sum[x] += val;
        x += (x & -x);
    }
}

long long query(int x)
{
    long long ans = 0;
    while(x){
        ans += sum[x];
        x -= (x & -x);
    }
    return ans;
}

int fa[maxn];
int find(int x)
{
    if(x == fa[x]){
        return x;
    }
    else
        return fa[x] = find(fa[x]);
}

int idx[maxn], cnt;//dfs序
int dep[maxn], f[maxn][20], r[maxn];

void dfs(int x, int par, int val)
{
    fa[x] = f[x][0] = par;
    dep[x] = dep[par] + 1;
    idx[x] = ++cnt;
    add(cnt, val);
    for(int i = 1; f[x][i - 1]; ++i){
        f[x][i] = f[f[x][i - 1]][i - 1];
    }
    for(int i = head[x]; i; i = e[i].nxt){
        if(par != e[i].v)
            dfs(e[i].v, x, e[i].val);
    }
    r[x] = cnt;
    add(cnt + 1, -val);
}

int lca(int x, int y)
{
    if(dep[x] < dep[y])swap(x, y);
    int h = dep[x] - dep[y];
    for(int i = 19; i >= 0; --i){
        if(h & (1 << i))
            x = f[x][i];
    }
    if(x == y)return x;
    for(int i = 19; i >= 0; --i){
        if(f[x][i] != f[y][i]){
            x = f[x][i];
            y = f[y][i];
        }
    }
    return f[x][0];
}

long long dis(int x, int y)
{
    int z = lca(x, y);
    return query(idx[x]) + query(idx[y]) - query(idx[z]) * 2;
}

int X[maxn], Y[maxn], W[maxn];
int main()
{
    cin>>t;
    while(t--){
        scanf("%d%d", &n, &q);
        for(int i = 0; i <= n; i++){
            head[i] = 0;
            fa[i] = i;
            sum[i] = 0;
        }
        cnt = 0;
        tot = 0;
        int r1 = 0, r2 = 0, bw = 0, id;
        for(int i = 1; i <= n; i++){
            int x, y, w;
            scanf("%d%d%d", &x, &y, &w);
            if(find(x) == find(y)){
                r1 = x;
                r2 = y;
                bw = w;
                id = i;
            }
            else{
                addedge(x, y, w);
                addedge(y, x, w);
                fa[find(x)] = find(y);
            }
            X[i] = x;
            Y[i] = y;
            W[i] = w;
        }
        dfs(1, 0, 0);
        while(q--){
            int op, x, y;
            scanf("%d%d%d", &op, &x, &y);
            if(op == 0){
                if(id == x)bw = y;
                else{
                    int u = (fa[X[x]] == Y[x]?X[x]:Y[x]);
                    add(idx[u], -W[x] + y);
                    add(r[u] + 1, W[x] - y);
                    W[x] = y;
                }
            }
            else{
                long long ans = dis(x, y);
                ans = min(ans, dis(r1, x) + dis(r2, y) + bw);
                ans = min(ans, dis(r1, y) + dis(r2, x) + bw);
                printf("%lld\n", ans);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wybooooooooo/article/details/81775854