A Stack or A Queue? ZOJ - 3210

Do you know stack and queue? They're both important data structures. A stack is a "first in last out" (FILO) data structure and a queue is a "first in first out" (FIFO) one.

Here comes the problem: given the order of some integers (it is assumed that the stack and queue are both for integers) going into the structure and coming out of it, please guess what kind of data structure it could be - stack or queue?

Notice that here we assume that none of the integers are popped out before all the integers are pushed into the structure.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

Each test case contains 3 lines: The first line of each test case contains only one integer Nindicating the number of integers (1 <= N <= 100). The second line of each test case contains N integers separated by a space, which are given in the order of going into the structure (that is, the first one is the earliest going in). The third line of each test case also contains Nintegers separated by a space, whick are given in the order of coming out of the structure (the first one is the earliest coming out).

Output

For each test case, output your guess in a single line. If the structure can only be a stack, output "stack"; or if the structure can only be a queue, output "queue"; otherwise if the structure can be either a stack or a queue, output "both", or else otherwise output "neither".

Sample Input

4
3
1 2 3
3 2 1
3
1 2 3
1 2 3
3
1 2 1
1 2 1
3
1 2 3
2 3 1

Sample Output

stack
queue
both
neither

AC代码(如果他是回文串那么就既是栈又是队列如果他和前一个的顺序相等那就是队列如果相反就是栈否则就啥也不是)

Select Code

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int main()
{
    std::ios::sync_with_stdio(false);
    int t, n, a[120], b[120], i, j;
    while(cin>>t)
    {
        while(t--)
        {
            int f = 1, f1 = 1, f2 = 1;
            cin>>n;
            for(i = 0;i<n;i++)
            {
                cin>>a[i];
            }
            for(i = 0;i<n;i++)
            {
                cin>>b[i];
            }
            for(i = 0,j = n-1;i<n,j>=0;i++,j--)
            {
                if(a[i]!=a[j])
                {
                    f = 0;
                    break;
                }
            }
            for(i = 0;i<n;i++)
            {
                if(b[i]!=a[i])
                {
                    f1 = 0;
                    break;
                }
            }
            for(i = 0,j = n-1;j>=0,i<n;i++,j--)
            {
                if(a[i]!=b[j])
                {
                    f2 = 0;
                    break;
                }
            }
            if(f==1)
            {
                printf("both\n");
            }
            else if(f1==1)
            {
                printf("queue\n");
            }
            else if(f2==1)
            {
                printf("stack\n");
            }
            else if(f==0&&f1==0&&f2==0)
                printf("neither\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41524782/article/details/81782256
今日推荐