A Stack or A Queue?

Do you know stack and queue? They're both important data structures. A stack is a "first in last out" (FILO) data structure and a queue is a "first in first out" (FIFO) one.

Here comes the problem: given the order of some integers (it is assumed that the stack and queue are both for integers) going into the structure and coming out of it, please guess what kind of data structure it could be - stack or queue?

Notice that here we assume that none of the integers are popped out before all the integers are pushed into the structure.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

Each test case contains 3 lines: The first line of each test case contains only one integer N indicating the number of integers (1 <= N <= 100). The second line of each test case contains N integers separated by a space, which are given in the order of going into the structure (that is, the first one is the earliest going in). The third line of each test case also contains N integers separated by a space, whick are given in the order of coming out of the structure (the first one is the earliest coming out).

<b< dd="">

Output

For each test case, output your guess in a single line. If the structure can only be a stack, output "stack"; or if the structure can only be a queue, output "queue"; otherwise if the structure can be either a stack or a queue, output "both", or else otherwise output "neither".

<b< dd="">

Sample Input

4
3
1 2 3
3 2 1
3
1 2 3
1 2 3
3
1 2 1
1 2 1
3
1 2 3
2 3 1

<b< dd="">

Sample Output

stack
queue
both
neither




#include<bits/stdc++.h>
using namespace std;


int s[110];
int b[110];


int main()
{
    int n;
    cin>>n;
    while(n--)
    {


        int t;
        cin>>t;
        for(int i=0; i<t; i++)
        {
            cin>>s[i];
        }


        for(int i=0; i<t; i++)
        {
            cin>>b[i];
        }
        int num = 0;
        int qwe = 0;
        for(int i=0; i<t; i++)
        {
           // printf("%d %d\n",s[i],b[t-i-1]);
            if(s[i] == b[i])
            {
                num++;
            }
            if(s[i] == b[t-i-1])
            {
                qwe++;
             //   printf("%d *",qwe);
            }
        }
        //printf("%d %d\n",num,qwe);
        if(num == t && qwe != t)
        {
            printf("queue\n");
        }
        else if(qwe == t && num != t)
        {
            printf("stack\n");
        }
        else if(qwe == t && num == t)
        {
            printf("both\n");
        }
        else
        {
            printf("neither\n");
        }
    }
}

猜你喜欢

转载自blog.csdn.net/wonder__/article/details/79747310