POJ1323 Game Prediction(贪心)

Game Prediction

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 



Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game. 

Input

The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros.

Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game. 
 

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4

题目大意:有m个人玩牌,每个人有n张牌,所以牌的总数是m*n,给出了你拥有的牌的号码,比赛规则是每个人依次出牌,最后数字大的那个人获胜

代码:
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int vis[1005];
int main()
{
    int n,m,t=1;;
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        memset(vis,0,sizeof(vis));
        int x,k=0,ans=0,maxx=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d",&x);
            vis[x]=1;
        }
        for(int i=n*m;i>0;i--)
        {
            if(k==m)
                break;
            if(vis[i])
            {
                k++;
                if(!maxx)
                    ans++;
                else
                    maxx--;
            }
            else
                maxx++;
        }
        printf("Case %d: %d\n",t++,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/81746267