PAT 1004. 成绩排名 (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

  第1行:正整数n
  第2行:第1个学生的姓名 学号 成绩
  第3行:第2个学生的姓名 学号 成绩
  ... ... ...
  第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
 
  
//C语言

#include <stdio.h>
#include <stdlib.h>
typedef struct student
{	
	char name[11];//字符数组,不能用 char *name定义
	char id[11];
	int grade;
}student;
int main()
{
   /* 我的第一个 C 程序 */
   //	printf("Hello, World! \n");
    int n;

	student max_stu;
    student min_stu;
    student stu;
    max_stu.grade=-1;
    min_stu.grade=101;
	scanf("%d\n",&n);    

    int i;
    for(i=0;i<n;i++)
    {
		scanf("%s %s %d",&stu.name,&stu.id,&stu.grade);
        
        if(stu.grade>max_stu.grade)
        {
			strcpy(max_stu.name,stu.name);
            strcpy(max_stu.id,stu.id);
            max_stu.grade=stu.grade;
        }
        if(stu.grade<min_stu.grade)
        {
			strcpy(min_stu.name,stu.name);
            strcpy(min_stu.id,stu.id);
            min_stu.grade=stu.grade;
        }
    }    
    printf("%s %s\n",max_stu.name,max_stu.id);
    printf("%s %s\n",min_stu.name,min_stu.id);
    //printf("grade=%d\n",max_stu.grade);
    system("pause");
    return 0;
}


猜你喜欢

转载自blog.csdn.net/wlfbitfc/article/details/79200417