PAT (Basic Level) Practice 1004 成绩排名 (20)

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为\

  第1行:正整数n
  第2行:第1个学生的姓名 学号 成绩
  第3行:第2个学生的姓名 学号 成绩
  ... ... ...
  第n+1行:第n个学生的姓名 学号 成绩

其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112
C++:
#include<cstdio>
struct student{
	char name[11]; 
	char id[11];
	int score;	
};
int main(){
	int min=0; int max=0;
	int n;
	struct student stu[110];
	scanf("%d",&n);
	
	for(int i=0;i<n;i++){
		scanf("%s%s",stu[i].name,stu[i].id);
		scanf("%d",&stu[i].score);
	/*	if(stu.score<min){
			min=stu.score;
		}
		
		if(stu.score>max){
			max=stu.score;
		}*/
	}
	
	struct student temp;	
	
	for(int i=0;i<n;i++){   //从大到小排好序 
		for(int j=i+1;j<n;j++){
			if(stu[i].score < stu[j].score){
				temp = stu[i];
				stu[i] = stu[j];
				stu[j] = temp;
			}
		}
	}
	 
	printf("%s %s\n",stu[0].name,stu[0].id);
	printf("%s %s",stu[n-1].name,stu[n-1].id);
	
	return 0;
}

注:

看完这个题目,觉得应该可以很快AC。看到有不同的数据类型,首先想到的就是结构体,结果发现我结构体部分的知识竟然生疏了。

struct student{
char name[11]; 
char id[11];
int score;

};

扫描二维码关注公众号,回复: 1736113 查看本文章

按照我的思路,则需要定义的是结构体数组,stu[100];

stu[i].score竟然被我写成了stu.score[i] ! (基础性错误,不过现在出现的所有错误都值得被保存下来,以防再次粗心)

另一种定义方法:

struct student{
char name[11]; 
char id[11];
int score;

}stu[100];   //全局

猜你喜欢

转载自blog.csdn.net/lili_code/article/details/80616208