Voting

Description

  A committee clerk is good at recording votes, but not so good at counting and figuring the outcome correctly. As a roll call vote proceeds, the clerk records votes as a sequence of letters, with one letter for every member of the committee:

  Y means a yes vote

  N means a no vote

  P means present, but choosing not to vote

  A indicates a member who was absent from the meeting

  Your job is to take this recorded list of votes and determine the outcome. Rules: There must be a quorum. If at least half of the members were absent, respond ‘need quorum’. Otherwise votes are counted. If there are more yes than no votes, respond ‘yes’. If there are more no than yes votes, respond ‘no’. If there are the same number of yes and no votes, respond ‘tie’.

Input

  The input contains of a series of votes, one per line, followed by a single line with the ‘#’ character. Each vote consists entirely of the uppercase letters discussed above. Each vote will contain at least two letters and no more than 70 letters.

Output

  For each vote, the output is one line with the correct choice ‘need quorum’, ‘yes’, ‘no’ or ‘tie’.

Sample Input

YNNAPYYNY

YAYAYAYA

PYPPNNYA

YNNAA

NYAAA

#

Sample Output

yes

need quorum

tie

no

need quorum

解析

给定一行字符串,记录串中各种字符出现的次数。然后按题目所有的规则判断输出

代码

#include<stdio.h>
#include<string.h>
#define MAX 100
int main()
{
    char str[MAX];
    while(~scanf("%s",str))
    {
        int len=strlen(str);
        if(len==1&&str[0]=='#')
            break;
        int i,j,absent=0,present=0,Yes=0,No=0;
        for(i=0;i<len;i++)
        {
            if(str[i]=='Y')
                Yes+=1;
            else if(str[i]=='N')
                No+=1;
            else if(str[i]=='P')
                present+=1;
            else if(str[i]=='A')
                absent+=1;
        }
        int temp=len%2==0?len/2:len/2+1;
        if(absent>=temp)
            printf("need quorum\n");
        else if(Yes>No)
            printf("yes\n");
        else if(No>Yes)
            printf("no\n");
        else if(Yes==No)
            printf("tie\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/81568140