sdut_1489_求二叉树的先序遍历

求二叉树的先序遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历

Input

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 

Output

 输出二叉树的先序遍历序列

Sample Input

2
dbgeafc
dgebfca
lnixu
linux

Sample Output

abdegcf
xnliu

Hint

Source

GYX

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char mid[55];
char post[55];

struct node
{
    char data;
    struct node *left;
    struct node *right;
};

struct node *creat(char *mid, char *post, int n)
{
    int k;
    if(n <= 0) return NULL;
    struct node *root;
    root = (struct node *)malloc(sizeof(struct node));
    root -> data = post[n - 1];
    for(k = 0; k < n; k++)
    {
        if(mid[k] == post[n - 1])
            break;
    }
    root -> left = creat(mid, post, k);                                        // k个节点数
    root -> right = creat(mid + k + 1, post + k, n - k - 1);         //  mid 要比 post 大一,原因是已经有一个post输出了
    return root;
};

void pre(struct node *root)
{
    if(root)
    {
        printf("%c", root -> data);
        pre(root -> left);
        pre(root -> right);
    }
}

int main()
{
    int t, n;
    while(~scanf("%d", &t))
    {
        while(t--)
        {
            scanf("%s", mid);
            scanf("%s", post);
            n = strlen(mid);
            struct node *root;
            root = creat(mid, post, n);
            pre(root);
            printf("\n");
        }
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/strongerXiao/article/details/81502431