Hexadecimal View

Description

Hexadecimal is very important and useful for computer programmers. You are requested to provide a hexadecimal view for given data. The hexadecimal view is made up of one or more rows. Every row except the last one represents 16 characters. Each row consists of three columns separated by a space:

  • addr: the 4-digit hexadecimal beginning address of this row.
  • dump: the hexadecimal representation of this row, separating every two characters by a whitespace. If there are less than 16 characters in the last row, pad it with spaces.
  • text: the ASCII translation of this row, with uppercase characters converted to lowercase and lowercase characters converted to uppercase.

Use lowercase for the letter digits. See sample for more details.

Input

There are multiple test cases. Each line is a test case. The line is made up of no less than 1 and no more than 4096 printable characters including spaces.

Output

For each test case, output its hexadecimal view. Do not output any extra spaces after the last character of text.

Sample Input

Hex Dump
#include <cstdio>
printf("Hello, World!\n");
main = do getLine >>= print . sum . map read . words

Sample Output

0000: 4865 7820 4475 6d70                     hEX dUMP
0000: 2369 6e63 6c75 6465 203c 6373 7464 696f #INCLUDE <CSTDIO
0010: 3e                                      >
0000: 7072 696e 7466 2822 4865 6c6c 6f2c 2057 PRINTF("hELLO, w
0010: 6f72 6c64 215c 6e22 293b                ORLD!\N");
0000: 6d61 696e 203d 2064 6f20 6765 744c 696e MAIN = DO GETlIN
0010: 6520 3e3e 3d20 7072 696e 7420 2e20 7375 E >>= PRINT . SU
0020: 6d20 2e20 6d61 7020 7265 6164 202e 2077 M . MAP READ . W
0030: 6f72 6473                               ORDS
#include<iostream>
#include<string>
typedef long long ll;
using namespace std;
int main()
{
	string s;
	while(getline(cin,s))
	{
		int l=s.length();
		for(int i=0;i<l;i+=16)
		{
			printf("%04x:",i);
			for(int j=i;j<i+16;j+=2)
			{
				if(j<l)printf(" %02x",s[j]);
				else printf("   ");
				if(j+1<l)printf("%02x",s[j+1]);
				else printf("  ");
			}
			printf(" ");
			for(int j=i;j<i+16&&j<l;j++)
			{
				if(s[j]>='a'&&s[j]<='z')
					printf("%c",s[j]-'a'+'A');
				else if(s[j]>='A'&&s[j]<='Z')
					printf("%c",s[j]-'A'+'a');
				else printf("%c",s[j]);
			}
			printf("\n");
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/UltraSurreal/article/details/81485765
今日推荐