mooc数据结构笔记(题来自mooc)

6-2 顺序表操作集(20 分)

本题要求实现顺序表的操作集。

函数接口定义:

List MakeEmpty(); 
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

其中List结构定义如下:

typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

各个操作函数的定义为:

List MakeEmpty():创建并返回一个空的线性表;

Position Find( List L, ElementType X ):返回线性表中X的位置。若找不到则返回ERROR;

bool Insert( List L, ElementType X, Position P ):将X插入在位置P并返回true。若空间已满,则打印“FULL”并返回false;如果参数P指向非法位置,则打印“ILLEGAL POSITION”并返回false;

bool Delete( List L, Position P ):将位置P的元素删除并返回true。若参数P指向非法位置,则打印“POSITION P EMPTY”(其中P是参数值)并返回false。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

#define MAXSIZE 5
#define ERROR -1
typedef enum {false, true} bool;
typedef int ElementType;
typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

List MakeEmpty(); 
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

int main()
{
    List L;
    ElementType X;
    Position P;
    int N;

    L = MakeEmpty();
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        if ( Insert(L, X, 0)==false )
            printf(" Insertion Error: %d is not in.\n", X);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        P = Find(L, X);
        if ( P == ERROR )
            printf("Finding Error: %d is not in.\n", X);
        else
            printf("%d is at position %d.\n", X, P);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &P);
        if ( Delete(L, P)==false )
            printf(" Deletion Error.\n");
        if ( Insert(L, 0, P)==false )
            printf(" Insertion Error: 0 is not in.\n");
    }
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

6
1 2 3 4 5 6
3
6 5 1
2
-1 6

输出样例:

FULL Insertion Error: 6 is not in.
Finding Error: 6 is not in.
5 is at position 0.
1 is at position 4.
POSITION -1 EMPTY Deletion Error.
FULL Insertion Error: 0 is not in.
POSITION 6 EMPTY Deletion Error.
FULL Insertion Error: 0 is not in.

#include <stdio.h>

#include <stdlib.h>
using namespace std;
#define MAXSIZE 5
#define ERROR -1
 typedef enum {False,True}Bool;
typedef int ElementType;
typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
}LNode;


List MakeEmpty();
Position Find( List L, ElementType X );
Bool Insert( List L, ElementType X, Position P );
Bool Delete( List L, Position P );


int main()
{
    List L;
    ElementType X;
    Position P;
    int N,i=0;


    L = MakeEmpty();
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        if ( Insert(L, X, 0)==False )
            printf(" Insertion Error: %d is not in.\n", X);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        P = Find(L, X);
        if ( P == ERROR )
            printf("Finding Error: %d is not in.\n", X);
        else
            printf("%d is at position %d.\n", X, P);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &P);
        if ( Delete(L, P)==False )
            printf(" Deletion Error.\n");
        if ( Insert(L, 0, P)==False )
            printf(" Insertion Error: 0 is not in.\n");
    }
    return 0;
}
List MakeEmpty(){
    List L;
    L=(List)malloc(sizeof(LNode));
    L->Last=-1;
    return L;
}
Position Find( List L, ElementType X ){//查找
    int i,j=0;
    for(i=0;i<=L->Last;i++){
        if(X==L->Data[i]){
            return i;
        }
    }
    return ERROR;
}
Bool Insert( List L, ElementType X, Position P ){//插入
    if(L->Last+1==MAXSIZE) {//若下标+1为max则顺序表已满[0,L->Last+1]
        printf("FULL");
        return False;
    }
    if(P<0||P>L->Last+1){
       printf("ILLEGAL POSITION");
    return False;
    }
    int i;
    for(i=L->Last;i>=P;i--){
        L->Data[i+1]=L->Data[i];
       }
       L->Data[P]=X;
       L->Last++;
       return True;
}
Bool Delete( List L, Position P ){
    if(P<0||P>L->Last) {//删除位置在[0,Last]之间
        printf("POSITION %d EMPTY",P);
        return False;
    }
    else {
        int i;
        for(i=P;i<L->Last;i++){
            L->Data[i]=L->Data[i+1];
        }
        L->Last--;
        return True;
    }
}

猜你喜欢

转载自blog.csdn.net/lianghudream/article/details/79057967