Fermat vs. Pythagoras

Description

Computer generated and assisted proofs and verification occupy a small niche in the realm of Computer Science. The first proof of the four-color problem was completed with the assistance of a computer program and current efforts in verification have succeeded in verifying the translation of high-level code down to the chip level. This problem deals with computing quantities relating to part of Fermat's Last Theorem: that there are no integer solutions of a^n + b^n = c^n for n > 2. Given a positive integer N, you are to write a program that computes two quantities regarding the solution of x^2 + y^2 = z^2, where x, y, and z are constrained to be positive integers less than or equal to N. You are to compute the number of triples (x,y,z) such that x < y < z, and they are relatively prime, i.e., have no common divisor larger than 1. You are also to compute the number of values 0 < p <= N such that p is not part of any triple (not just relatively prime triples).

Input

The input consists of a sequence of positive integers, one per line. Each integer in the input file will be less than or equal to 1,000,000. Input is terminated by end-of-file

Output

For each integer N in the input file print two integers separated by a space. The first integer is the number of relatively prime triples (such that each component of the triple is <=N). The second number is the number of positive integers <=N that are not part of any triple whose components are all <=N. There should be one output line for each input line.

Sample Input

10
25
100

Sample Output

1 4
4 9
16 27

Source

Duke Internet Programming Contest 1991,UVA 10

毕达哥拉斯三元方程组

满足方程x^2+y^2=z2的三元组(x,y,z)(x,y,z)为毕达哥拉斯三元组。当gcd(x,y,z)=1,称其为本原。

扫描二维码关注公众号,回复: 2677234 查看本文章

存在互质的正整数,一奇一偶,m,n满足

x=m^2-n^2

y=2*m*n

z=m^2+n^2

本题就利用了上述结论,找出方程本原,再成倍标记

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define maxn 1000005
using namespace std;
int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
}

bool flag[maxn];
int main()
{
     int N;
    while(~scanf("%d",&N))
    {
        int temp,m,n,ans1,ans2,x,y,z;
        ans1=ans2=0;
        memset(flag,false,sizeof(flag));
        temp=sqrt(N+0.5);
        for(int n=1;n<=temp;++n)
        {
        for(int m=n+1;m<=temp;++m)
        {
            if(m*m+n*n>N)
            break;
            if((n&1)!=(m&1))
            {
                if(gcd(m,n)==1)
                {
                    x=m*m-n*n;
                    y=2*m*n;
                    z=m*m+n*n;
                    ans1++;
                    int i;
                    for( i=1;;++i)
                    {
                        if(i*z>N)
                        break;
                        flag[i*x]=true;
                        flag[i*y]=true;
                        flag[i*z]=true;

                    }
                }
            }
        }

    }
    for(int i=1;i<=N;i++)
    if(!flag[i])
    ans2++;
printf("%d %d",ans1,ans2);
printf("\n");
}
    return 0;

}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/81474458