A - Rescue【BFS】

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. 

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards. 

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.) 

Input

First line contains two integers stand for N and M. 

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file. 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13
#include <bits/stdc++.h>
#include <queue>
using namespace std;

const int MAXN = 200 + 10;
vector<int> G[MAXN];
char str[MAXN][MAXN];
int vis[MAXN][MAXN];
int n, m;

struct node {
	int x, y;
	int step;
	friend bool operator < (node a, node b) {
		return a.step > b.step;// 优先用步数少的继续走,如果不排序,一定WAWAWA 
	}
};

int d[4][2] = {0,1,0,-1,1,0,-1,0};//方向数组 
void BFS(int x1, int y1, int x2, int y2) {
	memset(vis, 0, sizeof(vis));
	priority_queue<node> que;
	node e1, e2;
	e1.x = x1, e1.y = y1, e1.step = 0;
	que.push(e1);
	vis[x1][y1] = 1;
	int ans = -1;
	while(!que.empty()) {
		e1 = que.top();// 队列顶端的步数最少 
		que.pop();//移出队列 
		if(e1.x == x2 && e1.y == y2) {//到达终点 
			ans = e1.step;
			break;
		}
		for(int i = 0; i < 4; ++i) {//便利四个方向 int d[4][2] = {1, 0, -1, 0, 0, 1, 0, -1};
			e2.x = e1.x + d[i][0];// x 0 
			e2.y = e1.y + d[i][1];// y 1
			if(e2.x < 0 || e2.x >= n || e2.y < 0 || e2.y >= m) continue;//先判断是否出界?没有影响	int a[10]={1};	cout<<a[11];  "0"
			if(vis[e2.x][e2.y] == 1) continue;//三者的判断没有先后 
			if(str[e2.x][e2.y] == '#') continue;
			if(str[e2.x][e2.y] == 'x') e2.step = e1.step + 2;
			else e2.step = e1.step + 1;//'.'和'r'的情况,记得'r'也要加1 
//			if(str[e2.x][e2.y] == '.' || str[e2.x][e2.y] == 'r')
//				e2.step = e1.step + 1;
//			else if(str[e2.x][e2.y] == 'x')
//				e2.step = e1.step + 2;
			que.push(e2);// 
			vis[e2.x][e2.y] = 1;
		}
	}
	if(ans == -1) puts("Poor ANGEL has to stay in the prison all his life.");
	else printf("%d\n", ans);
}

int main() {
	int edx, edy, stx, sty;
	while(scanf("%d %d", &n, &m) != EOF) {
		for(int i = 0; i < n; ++i) scanf("%s", str[i]);//直接字符串否则超时
		for(int i = 0; i < n; ++i) {
			for(int j = 0; j < m; ++j) {
				if(str[i][j] == 'a') stx = i, sty = j;
				if(str[i][j] == 'r') edx = i, edy = j;
			}
		} 
		BFS(stx, sty, edx, edy);
	}
	return 0;
}

自己照着模板敲了一遍,一直样例过不了,啊啊啊啊,我。。。找了好久啊啊啊啊。。。结果是变量重复定义了。。。啊啊啊。

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
const int MAXN=300+20;
int n,m;
char ma[MAXN][MAXN];
int vis[MAXN][MAXN];

struct node{
	int x,y;
	int step;	
};
bool operator < (node a,node b){
		return a.step>b.step;
}

int dd[4][2]={0,1,0,-1,1,0,-1,0};
void BFS(int x1,int y1,int x2,int y2)
{
//	cout<<n<<'H'<<m<<endl;
	memset(vis,0,sizeof(vis));
	priority_queue <node> que;
	int ans=-1;
	node e1,e2,e3;
	e1.x=x1;
	e1.y=y1;
	e1.step=0;
	vis[x1][y1]=1;
	que.push(e1);
	while(!que.empty())
	{
		e2=que.top();
		que.pop();
		if(e2.x==x2 && e2.y==y2) 
		{
			ans=e2.step;
			break;
		}
		for(int i=0;i<4;i++)
		{
			e3.x=e2.x+dd[i][0];
			e3.y=e2.y+dd[i][1];
			if(e3.x<0||e3.x>=n||e3.y<0||e3.y>=m) continue;
			if(vis[e3.x][e3.y]) continue;
			if(ma[e3.x][e3.y]=='#') continue;
			if(ma[e3.x][e3.y]=='x') e3.step=e2.step+2;
			else e3.step=e2.step+1;
			vis[e3.x][e3.y]=1;
			que.push(e3);
 		}
	}
	if(ans==-1) cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
	else cout<<ans<<endl;
}
int main()
{
	int a,b,c,d;
//	int n,m;
	while(cin>>n>>m)
	{
//		cout<<n<<' '<<m<<endl; 
		for(int i=0;i<n;i++)
			cin>>ma[i];
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
			{
				if(ma[i][j]=='r')
				{
					c=i;d=j;
				}
				if(ma[i][j]=='a')
				{
					a=i;b=j;
				}
			}
		}
		BFS(a,b,c,d);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41333844/article/details/81315369
BFS