hdu 2037 今年暑假不AC

今年暑假不AC

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 69967    Accepted Submission(s): 37641


Problem Description
“今年暑假不AC?”
“是的。”
“那你干什么呢?”
“看世界杯呀,笨蛋!”
“@#$%^&*%...”

确实如此,世界杯来了,球迷的节日也来了,估计很多ACMer也会抛开电脑,奔向电视了。
作为球迷,一定想看尽量多的完整的比赛,当然,作为新时代的好青年,你一定还会看一些其它的节目,比如新闻联播(永远不要忘记关心国家大事)、非常6+7、超级女生,以及王小丫的《开心辞典》等等,假设你已经知道了所有你喜欢看的电视节目的转播时间表,你会合理安排吗?(目标是能看尽量多的完整节目)
 

Input
输入数据包含多个测试实例,每个测试实例的第一行只有一个整数n(n<=100),表示你喜欢看的节目的总数,然后是n行数据,每行包括两个数据Ti_s,Ti_e (1<=i<=n),分别表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。n=0表示输入结束,不做处理。
 

Output
对于每个测试实例,输出能完整看到的电视节目的个数,每个测试实例的输出占一行。
 

Sample Input
 
  
12 1 3 3 4 0 7 3 8 15 19 15 20 10 15 8 18 6 12 5 10 4 14 2 9 0
 

Sample Output
 
  
5
 

Author
lcy
 

Source
ACM程序设计期末考试(2006/06/07)


白书上第一个贪心例题的改版,有这类题型的真确的思想就是在当前可选的区段中,选择结束时间最早的,这样一直进行下去;每次选择可选区段时都要保证新加入的
的开始时间,要比当前区段的结束时间大。

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#include<vector>
#include<cmath>
using namespace std;
#define N 105
typedef long long LL;
int st, en;

struct time{
    int s;
    int e;
}t[N];

bool cmp(time x, time y){
    if(x.e < y.e){
        return true;
    }
    else
        return false;
}

int main(){
    int n;
    while(~scanf("%d", &n) && n){
        for(int i = 0; i < n; i++){
            scanf("%d%d", &st, &en);
            t[i].s = st;
            t[i].e = en;
        }
        sort(t, t+n, cmp);
        /*for(int i = 0; i < n; i++){
            cout << t[i].s << " " <<t[i].e << endl;
        }*/
        int index1 = 0;
        int cnt = 0;
        for(int i= 0; i < n; i++){
            if(t[i].s >= index1){
                index1 = t[i].e;
                cnt++;
            }
        }
        cout << cnt << endl;
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/guihaiyuan123/article/details/79965760