Ultra-QuickSort (归并排序)

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 

9 1 0 5 4 ,


Ultra-QuickSort produces the output 

0 1 4 5 9 .


Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
#include <stdio.h>
#define N 600000
int a[N];
int temp[600000];
long long w;
void Mergearray(int a[],int left,int mid,int right)
{
	int x,y,z;
	x=left,y=mid+1,z=0;
	while(x<=mid&&y<=right)
	{
		if(a[x]<=a[y]) temp[z++]=a[x++];
		else 
		{
			w+=y-left-z;
		temp[z++]=a[y++];}
	}
	while(x<=mid) temp[z++]=a[x++];
	while(y<=right) temp[z++]=a[y++];
	for(x=0;x<z;x++) a[left+x]=temp[x];
	
}
void Merge(int a[],int left,int right)
{
	int mid;
	if(left<right)
	{
		mid=(left+right)/2;
		Merge(a,left,mid);
		Merge(a,mid+1,right);
		Mergearray(a,left,mid,right);
	}
}
int main()
{
	int n,i;
	while(scanf("%d",&n)&&n)
	{
		w=0;
	for(i=0;i<n;i++) scanf("%d",&a[i]);
	Merge(a,0,n-1);
	printf("%lld\n",w);
    }
/*	for(i=0;i<n;i++)
	printf("%d ",a[i]);*/
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42434171/article/details/81393660
今日推荐