B - Treasure the new start, freshmen!

background: 
 A new semester comes , and the HDU also meets its 50th birthday. No matter what's your major, the only thing I want to tell you is:"Treasure the college life and seize the time." Most people thought that the college life should be colorful, less presure.But in actual, the college life is also busy and rough. If you want to master the knowledge learned from the book, a great deal of leisure time should be spend on individual study and practise, especially on the latter one. I think the every one of you should take the learning attitude just as you have in senior school. 
 "No pain, No Gain", HDU also has scholarship, who can win it? That's mainly rely on the GPA(grade-point average) of the student had got. Now, I gonna tell you the rule, and your task is to program to caculate the GPA. 
 If there are K(K > 0) courses, the i-th course has the credit Ci, your score Si, then the result GPA is 
 GPA = (C1 * S1 + C2 * S2 +……+Ci * Si……) / (C1 + C2 + ……+ Ci……) (1 <= i <= K, Ci != 0) 
 If there is a 0 <= Si < 60, The GPA is always not existed.
InputThe first number N indicate that there are N test cases(N <= 50). In each case, there is a number K (the total courses number), then K lines followed, each line would obey the format: Course-Name (Length <= 30) , Credits(<= 10), Score(<= 100). 
Notice: There is no blank in the Course Name. All the Inputs are legal OutputOutput the GPA of each case as discribed above, if the GPA is not existed, ouput:"Sorry!", else just output the GPA value which is rounded to the 2 digits after the decimal point. There is a blank line between two test cases. 
Sample Input
2
3
Algorithm 3 97
DataStruct 3 90
softwareProject 4 85
2
Database 4 59
English 4 81
Sample Output
90.10

Sorry!

乍一看是水题,实际好坑人的,输出结果要空一行,最后一组不空。

提交好多次都不对,直到把输入改为double型。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    char a[35];
    int n,k,i,flag;
    double sum,s,cre[105],sor[105];
    scanf("%d",&n);
    while(n--)
    {
        flag=k=0;
        sum=s=0;
        scanf("%d",&k);
        for(i=0;i<k;i++)
        {
            getchar();
            scanf("%s%lf%lf",a,&cre[i],&sor[i]);
        }
        for(i=0;i<k;i++)
        {
            if(sor[i]>=60)
            {
                sum=sum+sor[i]*cre[i];
                s=s+cre[i];
                flag++;
            }
        }
        if(flag==k)
        {
            printf("%.2lf\n",1.0*sum/s);
        }
        else printf("Sorry!\n");
        if(n)
            printf("\n");
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/deadmaus/article/details/79211874