E - 贪心

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. 
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000. 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain. 

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

贪心算法,按收益支出比排序,从大到小分配猫粮。

#include <stdio.h>
#include <algorithm>
#include <string.h>

using namespace std;

struct room
{
    double j,f,v;
}r[1010];

bool cmp(room a,room b)
{
    return a.v>b.v;
}

int main()
{
    int m,n;
    while(scanf("%d%d",&m,&n),m!=-1&&n!=-1)
    {
        memset(r,0,sizeof(r));
        int i;
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf",&r[i].j,&r[i].f);
            r[i].v=r[i].j/r[i].f;
        }
        sort(r,r+n,cmp);
        i=0;
        double sum=0;
        while(m!=0)
        {
            if(m>=r[i].f)
            {
                sum+=r[i].j;
                m-=r[i].f;
                i++;
            }
            else
            {
                sum+=m*r[i].v;
                m=0;
                i++;
            }
        }
        printf("%.3lf\n",sum);
    }

    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/deadmaus/article/details/81333550