字符串排序 (java comparator接口的使用)

先输入你要输入的字符串的个数。然后换行输入该组字符串。每个字符串以回车结束,每个字符串少于一百个字符。如果在输入过程中输入的一个字符串为“stop”,也结束输入。 
然后将这输入的该组字符串按每个字符串的长度,由小到大排序,按排序结果输出字符串。 

Input

字符串的个数,以及该组字符串。每个字符串以‘\n’结束。如果输入字符串为“stop”,也结束输入.

Output

将输入的所有字符串按长度由小到大排序输出(如果有“stop”,不输出“stop”)。 
 

Sample Input

5
sky is grey
cold
very cold
stop
3
it is good enough to be proud of
good
it is quite good

Sample Output

cold
very cold
sky is grey
good
it is quite good
it is good enough to be proud of

Hint

根据输入的字符串个数来动态分配存储空间(采用new()函数)。每个字符串会少于100个字符。 
测试数据有多组,注意使用while()循环输入。


import java.util.ArrayList;
import java.util.Collections;
import java.util.Comparator;
import java.util.List;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		while(sc.hasNextLine())
		{
			List<String>list = new ArrayList<>();
			int n = Integer.parseInt(sc.nextLine());//???????不知道为什么nextInt不可以
			for(int i=0;i<n;i++)
			{
				String temp=sc.nextLine();
				if(temp.equals("stop"))break;
				else list.add(temp);
			}
			
		Collections.sort(list, new Comparator<String>() {
				
		@Override
		public int compare(String s1, String s2) {
			int len1=s1.length();
			int len2=s2.length();
			return len1-(len2);
		}
		});
			for(String e:list)
				System.out.println(e);
			
	}
	}
}
	

猜你喜欢

转载自blog.csdn.net/weixin_41988545/article/details/81416014