俩个圆的重合面积

Tell me the area

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 0
Problem Description
    There are two circles in the plane (shown in the below picture), there is a common area between the two circles. The problem is easy that you just tell me the common area.

 

Input
There are many cases. In each case, there are two lines. Each line has three numbers: the coordinates (X and Y) of the centre of a circle, and the radius of the circle.
 

Output
For each case, you just print the common area which is rounded to three digits after the decimal point. For more details, just look at the sample.
 

Sample Input
 
  
0 0 2 2 2 1
 

Sample Output
 
  
0.108
 

#include<stdio.h>
#include<math.h>
#define PI acos(-1.0)
int main()
{
    double a1,b1,r1,a2,b2,r2,d;
    double A1,A2,s1,s2,s;
    while(scanf("%lf%lf%lf%lf%lf%lf",&a1,&b1,&r1,&a2,&b2,&r2)!=EOF)
    {
        d=sqrt((a2-a1)*(a2-a1)+(b2-b1)*(b2-b1));
        if(d>=r1+r2)    printf("0.000\n");
        else if(d<=fabs(r1-r2)&&d>=0)
        {
            if(r1>r2)
                    printf("%0.3lf\n",PI*r2*r2);
            else printf("%0.3lf\n",PI*r1*r1);
        }
        else {
            A1=2*acos((d*d+r1*r1-r2*r2)/(2*d*r1));
            A2=2*acos((d*d+r2*r2-r1*r1)/(2*d*r2));
            //cos(A1)=(d*d+r1*r1-r2*r2)/(2*d*r1);
            //cos(A2)=(d*d+r1*r1-r2*r2)/(2*d*r1);
            s1=0.5*r1*r1*sin(A1)+0.5*r2*r2*sin(A2);
            s2=(A1)/2*r1*r1+(A2)/2*r2*r2;
            s=s2-s1;
            printf("%.03lf\n",s);
        }
    }
}


猜你喜欢

转载自blog.csdn.net/smilelingling/article/details/79770944