1105 Spiral Matrix (25)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10^4^. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

思路:

关于螺旋矩阵,我参考了https://blog.csdn.net/YinJianxiang/article/details/60328969

C++:

#include <iostream>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
int func(int N) {
	int i = sqrt((double)N);
	while(i >= 1) {
		if(N % i == 0)
			return i;
		i--;
	}
	return 1;
}
int cmp(int a, int b) {return a > b;}
int main() {
	int N, m, n, t = 0;
	scanf("%d", &N);
	n = func(N);
	m = N / n;
	vector<int> a(N);
	for (int i = 0; i < N; i++)
		scanf("%d", &a[i]);
	sort(a.begin(), a.end(), cmp);
	vector<vector<int> > b(m, vector<int>(n));
	int level = m / 2 + m % 2;
	for (int i = 0; i < level; i++) {
		for (int j = i; j <= n - 1 - i && t <= N - 1; j++)
			b[i][j] = a[t++];
		for (int j = i + 1; j <= m - 2 - i && t <= N - 1; j++)
			b[j][n - 1 - i] = a[t++];
		for (int j = n - i - 1; j >= i && t <= N - 1; j--)
			b[m - 1 - i][j] = a[t++];
		for (int j = m - 2 - i; j >= i + 1 && t <= N - 1; j--)
			b[j][i] = a[t++];
	}
	for (int i = 0; i < m; i++) {
		for (int j = 0 ; j < n; j++) {
			printf("%d", b[i][j]);
			if (j != n - 1) printf(" ");
		}
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ysq96/article/details/81346924