PAT 1105 Spiral Matrix (25)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10^4^. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76 

程序:

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
bool cmp(int a,int b)
{
  return a > b;
}
int main()
{
  int num;
  scanf("%d",&num);
  vector<int> v(num);
  for(int i = 0; i < num; i++)
  {
    scanf("%d",&v[i]);
  }
  sort(v.begin(),v.end(),cmp);
  int m = 0, n = 0;
  for(int i = 1; i * i <= num; i++)
  {
    if(num % i == 0)
    {
      n = i;
      m = num / i;
    }
  }
  // int** arr = new int* [m+1];
  // for(int i = 0; i < m + 1; i++)
  // {
  //   arr[i] = new int [n+1];
  // }
  int arr[m][n];
  for(int i = 0; i < m; i++)
  {
    for(int j = 0; j <n; j++)
       arr[i][j] = 0;
  }
  int k = 0;
  int i = 0,j = -1;
  while(k < v.size())
  {
    while(!arr[i][j+1] && j + 1 < n && k < v.size()) arr[i][++j] = v[k++];
    while(!arr[i+1][j] && i + 1 < m && k < v.size()) arr[++i][j] = v[k++];
    while(!arr[i][j-1] && j - 1 >= 0 && k < v.size()) arr[i][--j] = v[k++];
    while(!arr[i-1][j] && i - 1 >=0 && k < v.size()) arr[--i][j] = v[k++];
  }
  for(int x = 0; x < m; x++)
  {
    printf("%d",arr[x][0]);
    for(int y = 1; y < n; y++)
    {
      printf(" %d",arr[x][y]);
    }
    printf("\n");
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/hickey_chen/article/details/80983038